开发者社区> 问答> 正文

qt-sdk编译qmake无法生存.o文件

我已经在Linux平台下面安装了qt-sdk,sudo apt-get install qt-sdk安装的,设置环境变量了
export QMAKESPEC=/home/user/EPC-6708/fsl-linaro-toolchain/qt-sdk/mkspecs/qws/linux-g++-mx/
export PATH=$PATH:/home/user/EPC-6708/fsl-linaro-toolchain/qt-sdk/bin/
两个,接着写一个简单的hello1.cpp,
开始编译,qmake -project ,生成hello1.pro文件
qmake,生成Makefile文件,我进去查看了 QMAKE = /usr/bin/qmake,这里我就郁闷了为什么QMAKE不是我想要的
/home/user/EPC-6708/fsl-linaro-toolchain/qt-sdk/bin/qmake(进去改了也不行)
接着就是无法编译出hello.o文件了,无法编译出可执行文件了。
user@user-desktop:~/share-EPC-6708/QThello$ make
arm-none-linux-gnueabi-g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../EPC-6708/fsl-linaro-toolchain/qt-sdk/mkspecs/qws/linux-g++-mx -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I. -I. -o hello1.o hello1.cpp
In file included from /usr/include/qt4/QtCore/qtextcodec.h:45:0,
from /usr/include/qt4/QtCore/QtCore:3,
from /usr/include/qt4/QtGui/QtGui:3,
from hello1.cpp:1:
/usr/include/qt4/QtCore/qatomic_i386.h: In destructor 'QString::~QString()':
/usr/include/qt4/QtCore/qatomic_i386.h:132:29: error: impossible constraint in 'asm'
make * [hello1.o] 错误1
这个编译搞了三四天了,还是不懂怎么破!!!!!!!!!求大牛!在线等!!急!!!

展开
收起
杨冬芳 2016-07-12 12:20:58 4480 0
1 条回答
写回答
取消 提交回答
问答排行榜
最热
最新

相关电子书

更多
从 SDK 到编解码:视频直播架构解析 立即下载
跨平台的云服务SDK需要什么 立即下载
一个跨平台的云服务SDK需要什么 立即下载

相关镜像