我已经没法忍受了,64位 ubuntu下eclipse频繁崩溃问题-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

我已经没法忍受了,64位 ubuntu下eclipse频繁崩溃问题

前一段时间换回了Ubuntu开始工作,安装jdk,eclipse后,发现eclipse时常崩溃,崩溃情况如下:

打开小窗口的时候会崩溃,比如删除文件,这个时候因为会有一个确认的窗口,比如rename等,只要是这个操作涉及到弹出的窗口,那么eclipse绝对会崩溃。

我目前怀疑问题只有来自三个地方,jdk,eclipse,操作系统。

目前我的jdk版本是1.7,eclipse版本是4.2,ubuntu是12.10

后来我就不用eclipse改用idea了,但是今天因为要学习jfinal,开始出现的问题很多,目前不敢换别的ide来开发,只能老老实实用eclipse,然后我实在无法忍受这个崩溃的问题了。

最后问一下各路大神,有谁碰到过这样的情况,最后是怎么解决的。我现在先去更换jdk,换成1.7的,然后再去更换新的eclipse看看。

展开
收起
爵霸 2016-06-06 11:46:48 2290 0
1 条回答
写回答
取消 提交回答
  • 爵霸

    呃 好像上次和明月在群里说过这个事情...

    之前在fedora上把ibus拼音输入法卸载,换成fcitx输入法,然后Eclipse就会在诸如rename,移动文件,打开文件还有个别快捷键时有比较高概率的直接崩溃。因为Google到很多关于fcitx和Eclipse冲突的反馈,重新换回ibus之后就没有再出现。具体log当时没细看。不过系统不完全一样倒是。

    2019-07-17 19:28:07
    赞同 展开评论 打赏
问答排行榜
最热
最新
相关电子书
更多
15分钟打造你自己的小程序更新版
立即下载
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载