开发者社区 > 通义大模型 > 正文

jetbrain IDE 无法正常安装 TONGYI Lingma plugin

jetbrain IDE 无法正常安装 TONGYI Lingma plugin 最新版,包括 idea 和 pycharm。
报错信息如下
Plugin "TONGYI Lingma - Your AI Coding Assistant. Type less, Code more." was not installed: Cannot download 'https://downloads.marketplace.jetbrains.com/files/17809/552735/tongyi-jetbrains-1.3.0.zip?updateId=552735&pluginId=17809&family=INTELLIJ&uuid=201021243aece43-ef1d-4942-866c-9a76fbe647ca&updatedFrom=&code=IU&build=241.14494.240': Read timed out , response: 200 OK

展开
收起
夏目同学 2024-06-14 16:42:45 1125 0
1 条回答
写回答
取消 提交回答
  • 遇到这个问题,可以尝试以下几个步骤来解决JetBrains IDE中无法安装通义灵码插件的问题:

    1. 检查网络连接:确保你的网络连接稳定,并且没有被防火墙或代理设置阻挡。报错提示“Read timed out”,可能是因为网络不稳定或下载超时导致。
    2. 重试安装:有时候可能是暂时的网络波动或者 JetBrains Marketplace 的服务器问题,可以稍后再尝试安装。
    3. 手动下载安装:既然直接通过IDE市场下载有问题,你可以尝试直接从JetBrains Marketplace网站上手动下载插件的ZIP文件,然后在IDE中选择“Install Plugin from Disk”进行安装。根据错误信息中的URL,直接访问这个链接:https://downloads.marketplace.jetbrains.com/files/17809/552735/tongyi-jetbrains-1.3.0.zip,尝试手动下载ZIP文件。
    4. 调整IDE网络设置:如果使用了代理服务器,确保IDE的网络设置正确配置了代理信息。在IDE的设置中找到“HTTP Proxy”设置,正确填写代理服务器信息。
    5. 清除缓存重启:有时IDE的缓存问题也可能导致插件安装失败。可以尝试清理缓存并重启IDE。操作路径通常是File > Invalidate Caches / Restart...,然后选择Invalidate and Restart
    6. 检查IDE版本兼容性:确认你的IDE版本与通义灵码插件的版本兼容。错误信息中提到的build=241.14494.240指的是你的IDE版本,确保这个版本在插件支持的范围内。可以查看插件的发布说明或联系技术支持确认。
    2024-06-14 16:54:04
    赞同 58 展开评论 打赏

通义千问大模型家族全面升级更大参数规模模型首次面世,全新通义千问2.0版本欢迎体验。https://tongyi.aliyun.com/

相关电子书

更多
D2前端工程下一站 IDE ——上坡&吭头 立即下载
D2前端工程下一站 IDE 立即下载
低代码开发师(初级)实战教程 立即下载