开发者社区 > 视觉智能 > 文字识别 > 正文

文字识别OCR中,下载sdk php5.6 报错,为什么?

文字识别OCR中,用composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
composer require alibabacloud/ocr-api-20210707 2.0.7下载sdk php5.6 报错,为什么?

展开
收起
wenti 2024-05-05 12:25:54 19 0
2 条回答
写回答
取消 提交回答
  • 从事java行业9年至今,热爱技术,热爱以博文记录日常工作,csdn博主,座右铭是:让技术不再枯燥,让每一位技术人爱上技术

    您好,文字识别OCR对于PHP的相关环境要求最低要求 PHP 5.6,同时需要注意 执行 composer 安装 SDK 的 PHP 版本要小于或等于实际运行时的 PHP 版本。 例如,在 PHP7.2 环境下安装 SDK 后生成 vendor 目录,只能在 PHP7.2 以上版本使用,如果拷贝到 PHP5.6 环境下使用,会出现依赖版本不兼容问题
    image.png
    关于PHP环境要求的更多详细内容可以参考文档:文档
    建议您按照文档要求再次尝试看是否可以。

    2024-05-08 15:29:50
    赞同 展开评论 打赏
  • 尝试升级下php版本——该回答整理自钉群“【官方】阿里云OCR公共云客户交流群”

    2024-05-05 20:40:29
    赞同 展开评论 打赏

文字识别技术可以灵活应用于证件文字识别、发票文字识别、文档识别与整理等行业场景,满足认证、鉴权、票据流转审核等业务需求。

相关电子书

更多
从 SDK 到编解码:视频直播架构解析 立即下载
跨平台的云服务SDK需要什么 立即下载
一个跨平台的云服务SDK需要什么 立即下载