开发者社区 > 大数据与机器学习 > 实时计算 Flink > 正文

Flink1.18.1和CDC2.4.1 本地没问题,提交任务到服务器报错,下图是报错和全jar包

image.png
image.png

展开
收起
亮亮回来了 2024-03-01 15:55:32 89 0
3 条回答
写回答
取消 提交回答
  • 这个错误是由于服务器上的JDK版本与本地不一致导致的。你需要确保服务器上的JDK版本与本地一致,以避免因版本不匹配导致的问题。

    是因为环境变量配置在读取的时候 顺序不一致,或者有多个jdk版本 安装
    image.png

    去对应环境变量 里面查找对应 jdk配置的路径信息:
    然后把需要的 jdk版本放在第一位 ,因为 oracle也自带一个jdk,如果你在配置环境变量时,将jdk配在oracle后面,系统则会默认查找oracle的jdk,导致你的配置根本没起到作用。

    参考 https://blog.csdn.net/sqL520lT/article/details/133882542

    2024-03-02 15:45:51
    赞同 展开评论 打赏
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    这个错误是由于Java的VerifyError引起的,通常是由于编译时和运行时环境不一致导致的。可能的原因有:

    1. 使用了不同版本的JDK进行编译和运行。请确保编译和运行时使用的JDK版本一致。

    2. 类库冲突。可能是由于项目中存在多个版本的相同类库,导致运行时加载了错误的类库。请检查项目的依赖关系,确保没有重复或冲突的类库。

    3. 使用了不兼容的第三方库。请检查项目中使用的第三方库是否与Flink和CDC的版本兼容。

    建议按照以下步骤进行排查:

    1. 确认编译和运行时使用的JDK版本是否一致。

    2. 检查项目的依赖关系,确保没有重复或冲突的类库。可以使用Maven或Gradle等构建工具进行依赖管理。

    3. 检查项目中使用的第三方库是否与Flink和CDC的版本兼容。可以参考官方文档或社区讨论获取更多信息。

    2024-03-01 17:55:47
    赞同 展开评论 打赏
  • 十分耕耘,一定会有一分收获!

    楼主你好,根据报错信息java.lang.VerifyError: Bad returntypeException,这通常是由于依赖版本不匹配或者编译器优化问题导致的,你可以确保服务器上的 Flink 版本和 CDC 版本与本地一致,特别注意是否有不同的依赖版本。

    然后检查服务器上是否存在其他版本或冲突的 jar 包,与 Flink 或 CDC 的相关依赖发生冲突可能导致此问题,还有检查服务器上的 JVM 版本,并确保与本地 JVM 版本相同。

    2024-03-01 16:46:11
    赞同 展开评论 打赏

实时计算Flink版是阿里云提供的全托管Serverless Flink云服务,基于 Apache Flink 构建的企业级、高性能实时大数据处理系统。提供全托管版 Flink 集群和引擎,提高作业开发运维效率。

相关产品

  • 实时计算 Flink版
  • 相关电子书

    更多
    Flink CDC Meetup PPT - 龚中强 立即下载
    Flink CDC Meetup PPT - 王赫 立即下载
    Flink CDC Meetup PPT - 覃立辉 立即下载