开发者社区 > 大数据与机器学习 > 实时计算 Flink > 正文

flink 1.18必须配套JDK11吗 1.8是不是不行了呢?

flink 1.18必须配套JDK11吗 1.8是不是不行了呢?

展开
收起
三分钟热度的鱼 2023-11-22 18:44:04 722 1
2 条回答
写回答
取消 提交回答
  • 对于Flink 1.18来说,它推荐使用Java 11作为运行环境。这是因为从Flink 1.10.0版本开始,就增加了对Java 11的支持,并且Java 11已经成为了Flink在docker镜像中的默认Java版本。当然,如果你一定要在Java 1.8的环境中运行Flink 1.18也是可以的,但是你需要做一些额外的配置。具体来说,你需要在conf/flink-conf.yaml文件中添加三行配置,分别是:env.java.home: /data/jdk1.8.0_202,containerized.master.env.JAVA_HOME: /data/jdk1.8.0_202,containerized.taskmanager.env.JAVA_HOME: /data/jdk1.8.0_202。此外,还需要注意,Flink的源码编译依赖于JDK和Maven的环境,且JDK必须在1.8版本以上,Maven必须在3.0版本以上,否则会导致编译出错。

    总的来说,对于Flink 1.18来说,虽然它可以在Java 1.8环境下运行,但是为了获得最佳的运行效果和性能,还是推荐使用Java 11。同时,如果选择使用Java 1.8,就需要进行一些额外的配置。

    2023-11-28 11:53:09
    赞同 展开评论 打赏
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    根据 Flink 官方文档中关于 Java 版本支持的情况,从 Flink 1.18 版本开始,它正式移除了对 JDK 8 的支持,并且只支持 Java 11 及更高版本。这意味着您只能在 Java 11 或更高的环境中运行 Flink 1.18 及以上版本。
    为了保证 Flink 的稳定性,请确保您的系统环境中安装的是 Java 11 及以上的版本。请参考 Flink 官方文档中的详细说明,以确保 Flink 正确安装和运行

    2023-11-22 22:42:49
    赞同 1 展开评论 打赏

实时计算Flink版是阿里云提供的全托管Serverless Flink云服务,基于 Apache Flink 构建的企业级、高性能实时大数据处理系统。提供全托管版 Flink 集群和引擎,提高作业开发运维效率。

相关产品

  • 实时计算 Flink版
  • 相关电子书

    更多
    Flink CDC Meetup PPT - 覃立辉 立即下载
    Flink CDC Meetup PPT - 孙家宝 立即下载
    Flink CDC Meetup PPT - 徐榜江 立即下载