开发者社区 > 大数据与机器学习 > 人工智能平台PAI > 正文

在机器学习PAI中alink可以在hadoop3的yarn集群环境中运行吗?

"alink可以在hadoop3的yarn集群环境中运行吗? 我看pom文件里面配置的都是2.8.0"

展开
收起
JWRRR 2023-05-04 22:21:37 311 0
2 条回答
写回答
取消 提交回答
  • 值得去的地方都没有捷径

    从技术上讲,Alibaba的alink可以在Hadoop 3的YARN集群环境中运行,但需要将它的依赖项配置为Hadoop 3。根据我的了解,当前Alink 2.3版本支持Hadoop 3。因此,您需要在您的项目中更新Alink的版本并将其所需的依赖项更改为Hadoop 3。

    如果您按照pom文件中的配置加载alink并运行,在不进行任何更改的情况下,alink将不兼容Hadoop 3环境,并且您可能会遇到与Classpath和API版本不兼容等问题。

    2023-05-05 09:47:01
    赞同 1 展开评论 打赏
  • 阿里云机器学习API中的alink提供了分布式机器学习训练框架,能够在阿里云的E-MapReduce托管的Hadoop、Spark、Flink等多种计算引擎上运行,但是其是否能在Hadoop3的Yarn集群环境中正常运行仍需视具体的业务场景而定。

    一般来说,Hadoop3与Hadoop2相比引入的变化比较大,其中包括了对许多的类库与框架的升级,并引入了Yarn Timeline ServiceV2等新的功能,这些可能会与alink的运行有一定的兼容性问题。因此,在Hadoop3的Yarn集群环境中运行alink,需要进行一些额外的配置调整,才可以保证alink能够正常运行。

    建议在尝试在Hadoop3的Yarn集群环境中运行alink前,可以先熟悉阿里云机器学习API的使用方式,同时了解Hadoop3的升级与变化以及涉及到的相关技术和概念,可以参考阿里云官方文档和相关技术论坛以获取更多的信息和支持。

    2023-05-05 07:54:16
    赞同 展开评论 打赏

相关产品

  • 人工智能平台 PAI
  • 热门讨论

    热门文章

    相关电子书

    更多
    大规模机器学习在蚂蚁+阿里的应用 立即下载
    基于Spark的面向十亿级别特征的 大规模机器学习 立即下载
    基于Spark的大规模机器学习在微博的应用 立即下载