flink1.15.3+flinkcdc2.3.0,执行select *语句报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

flink1.15.3+flinkcdc2.3.0,执行select *语句报错

Flink SQL> select * from test; [ERROR] Could not execute SQL statement. Reason: java.lang.ClassNotFoundException: com.ververica.cdc.debezium.utils.ResolvedSchemaUtils

展开
收起
aliyun6814663100 2022-12-01 21:58:12 473 0
1 条回答
写回答
取消 提交回答
  • 喜欢猪猪
    网站:http://ixiancheng.cn/ 微信订阅号:小马哥学JAVA

    1.java运行环境的jdk版本比class文件的编译版本低了导致 2.class文件的访问权限或者所在目录的访问权限有问题,导致java无法读这个文件 3.jar包有错误,查看jar是否有漏或者重新导入jar包 这个问题,首先可以排查一下是否有这个表。建议重新创建表: 微信截图_20221203121015.png

    然后查看一下创建的表是否成功

    2022-12-03 12:14:57
    赞同 1 展开评论 打赏
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载