ECS 服务器怎么安装vagrant ?-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

ECS 服务器怎么安装vagrant ?

2020-10-20 18:17:35 626 1

我执行了 vagrant up, 结果报如下错误

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'ubuntu'...
==> default: Matching MAC address for NAT networking...
==> default: Setting the name of the VM: ubuntu_default_1602823915197_80926
Vagrant is currently configured to create VirtualBox synced folders with
the `SharedFoldersEnableSymlinksCreate` option enabled. If the Vagrant
guest is not trusted, you may want to disable this option. For more
information on this option, please refer to the VirtualBox manual:

  https://www.virtualbox.org/manual/ch04.html#sharedfolders

This option can be disabled globally with an environment variable:

  VAGRANT_DISABLE_VBOXSYMLINKCREATE=1

or on a per folder basis within the Vagrantfile:

  config.vm.synced_folder '/host/path', '/guest/path', SharedFoldersEnableSymlinksCreate: false
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "f4c5917e-c869-47f2-af61-fa04c99334af", "--type", "headless"]

Stderr: VBoxManage: error: VT-x is not available (VERR_VMX_NO_VMX)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

我执行了 kvm-ok,结果如下:
INFO: Your CPU does not support KVM extensions. KVM acceleration can NOT be used

请问应该怎么解决这个问题?

取消 提交回答
全部回答(1)
  • 淡味丶依然
    2021-02-07 11:15:54

    云服务器是不支持再次虚拟化的。

    因为云主机本身就是一种虚拟化,就像是我在我自己的电脑上安装了虚拟机之后,进入虚拟机是不能再次虚拟化一样。

    Your CPU does not support KVM extensions. KVM acceleration can NOT be used 这句话翻译过来的意思就是:您的cpu不支持kvm扩展。

    0 0
相关问答

1

回答

slb后端服务器可以混挂经典网络ECS和专有网络ECS吗?

2022-03-31 14:16:44 758浏览量 回答数 1

1

回答

云服务器中怎么安装Nginx呢?

2021-12-13 13:56:49 278浏览量 回答数 1

1

回答

在云服务器环境的搭建中mysql怎么安装呢?

2021-12-13 13:43:31 356浏览量 回答数 1

1

回答

Linux云服务器怎么安装gd库

2019-10-11 09:58:17 1058浏览量 回答数 1

1

回答

云服务器ECS 不会安装FTP

2018-12-30 16:45:38 472浏览量 回答数 1

1

回答

云服务器ECS重启卡死

2018-11-15 13:21:16 825浏览量 回答数 1

3

回答

ECS服务器安全问题

2018-08-20 16:21:32 672浏览量 回答数 3

1

回答

聚石塔服务器怎么安装php版本

2017-06-28 11:19:38 2499浏览量 回答数 1

0

回答

云服务器怎么安装PPTPD

2013-01-27 16:20:30 8079浏览量 回答数 0

4

回答

问下你们的服务器是怎么安装sql2000的

2013-01-11 06:54:53 5139浏览量 回答数 4
+关注
0
文章
2
问答
问答排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载