PHP5.2.14升级到PHP5.3版本 对网站有什么影响?403.10 禁止访问:配置无效  -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

PHP5.2.14升级到PHP5.3版本 对网站有什么影响?403.10 禁止访问:配置无效 

kun坤 2020-05-26 12:46:51 53

"

服务器环境是WIN2003+Apache2.0.63+PHP5.2.14+MYSQL5.0

Apache每天都会出现假死现象,所有网站不能访问,必须手动重启Apache才行。

试过网上对Apache的各种配置,还是不行,有解决的同志谢谢指教啊。

系统不能换,WEB服务器类型不能换。

所以只能换Apache版本 PHP版本了。

如果PHP5.2.14升级到PHP5.3版本 对客户的网站有什么影响?

"
分享到
取消 提交回答
全部回答(1)
  • kun坤
    2020-05-26 21:18:11

    你这种配置就是作死的节奏啊,win2003+apache  这不是作死么,千奇百怪的问题,还不好监控,至于php5.2.X 升级到php5.3,大部分都是有问题的,要改点代码,具体咨询开发商

    ######

    纯代码角度看,php5.2系列升级到5.3系列有部分函数被废弃了,需要注意测试一遍看是否有使用被废弃的函数,当然这种可能不大,但跑一遍安心。从我的经验看最大的变化是“调用时传递引用被弃用.”,我曾经的项目就有过这个问题,但其实代码改动也不太大。基本上没什么问题,内测一遍,没问题就升吧。 逐步跟上版本节奏是没有问题的,官方有升级文档,告诉那些东西被废弃,跟着来就可以了。就怕那些长期不升级的,就比较可怕了。

    我是建议一次性升级到php5.4

    0 0
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章