智能出行引擎有哪些开发流程?-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

智能出行引擎有哪些开发流程?

剑曼红尘 2020-03-24 15:19:09 159

智能出行引擎有哪些开发流程?

分享到
取消 提交回答
全部回答(1)
  • 剑曼红尘
    2020-03-24 15:23:09

    步骤1:配置开发环境

    配置开发环境-Mac环境

    前提条件 已安装Node.js。

    Node.js版本建议为8系统,推荐8.10。

    若未安装,请下载操作系统对应的安装包进行安装。

    已安装VS Code。

    若未安装,请下载操作系统对应的安装包进行安装。

    操作步骤

    1. 打开Bash软件。

    2. 执行以下命令,安装Honeycomb。

    sudo npm install honeycomb-cli -g

    1. 执行以下命令,配置Honeycomb。

    honeycomb config registry registry=https://registry.npm.taobao.org

    1. 选择需要创建应用的文件夹,执行以下命令,初始化城市大脑应用。

    cd $app_root //请根据实际情况替换

    honeycomb init -t brain

    初始化成功后,对应文件夹下会生成代码目录,如下图所示。

    11.png

    1. 安装cnpm。

    sudo npm install -g cnpm --registry=https://registry.npm.taobao.org

    1. 执行以下命令,安装运行依赖环境。

    make install

    若遇到如下错误:

    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

    请执行以下命令。

    xcode-select –install

    1. 执行以下命令,安装阿里云API网关的依赖。

    cnpm install aliyun-api-gateway -S

    1. 执行以下命令,启动项目。

    honeycomb start

    启动项目成功后,访问 http://localhost:8001/app/app-name,即可在本地环境中查看运行效果,如下图所示。

    注意:启动项目成功后,请不要关掉Bash窗口。

    22.png

    配置开发环境-Windows环境

    前提条件 已安装Node.js。

    1. Node.js版本建议为8系统,推荐8.10。

    若未安装,请下载操作系统对应的安装包进行安装。

    1. 已安装VS Code。

    若未安装,请下载操作系统对应的安装包进行安装。

    1. 已完成gitbash的安装。

    若未安装,请下载操作系统对应的安装包进行安装。

    注意事项:

    • 选择安装目录 c:\lib\git。
    • 出现git命令工具和cmd相关的选项(3选1的场景),请选择第三个。 安装工具包补丁。

    • 下载如下工具包,解压,将里面所有的文件copy到 GitBash 安装目录下的 usr\bin\ 中。此例中为 c:\lib\git\usr\bin\。 cmd-tools.zip

    0 0
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章