【新手】请问Aliyun linux服务器安装缺少包怎么搞-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

【新手】请问Aliyun linux服务器安装缺少包怎么搞

学无止雪 2016-07-16 15:52:37 4840
【新手】新买的Aliyun Linux服务器,但缺少这几个包,使用yum安装的时候,下面几个包始终安装不上


单独使用的yum install compat-gcc这个命令来安装的,几个没安装上的都是直接使用这个命令来安装的,都是没法安装上,
如下图:




请问到底需要怎样安装才能安装上啊?我是想要试着安装一个Oracle 10g的数据库来自己学者数据库的自动备份。
需要学习的东西还很多,请各位帮帮忙。谢谢
Oracle 关系型数据库 Linux 数据库
分享到
取消 提交回答
全部回答(2)
  • dongshan8
    2016-07-16 16:54:11
    楼主您好,

    或许您需要先检查一下yum的安装源是否完整和有效。

    这里有一篇文章,您可以参考一下: http://www.hongxuejing.com/linux/aliyunlinuxgenggaiyum-18.html

    或者您可以直接将系统更换到相对较熟悉的CentOS系统。

    -------------------------

    回 3楼(学无止雪) 的帖子
    您好,

    为您再搜索了一下,或许这个对您有帮助: http://my.oschina.net/dxqr/blog/369099

    Oracle 10g 是不是相对来说,已经停止支持,官方不不提供下载了?
    0 0
  • 学无止雪
    2016-07-16 15:53:43
    Re【新手】请问Aliyun linux服务器安装缺少包怎么搞
    自己占楼,求解啊...

    -------------------------

    回 2楼dongshan8的帖子
    我试着照你给的链接试了下,使用如下图:

    我装的yum-3.2.29-73.el6.centos.noarch.rpm是这个版本的yum,但是在安装的时候说python-urlgrabber版本必须大于等于3.9.1-10 ,后来我安装了python-urlgrabber-3.9.1-11的包,再次安装yum的时候还是提示python-urlgrabber版本不对。不知道为什么。截图上面都有,请问这是什么原因?
    0 0
添加回答
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题
推荐课程