使用阿里云ECS2003标准版无法安装SQL2005系统的问题-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

使用阿里云ECS2003标准版无法安装SQL2005系统的问题

北京亿网 2014-12-06 08:15:09 34883
问题描述 : 在安装mssql2005时,安装CD1顺利完成,在安装CD2时无法进行,双击安装文件后自动关闭,无提示!怎么解决?

下面是阿里云工程师对我们这个提问的回复,结贴了,大家以后不要在讨论了。  
售后工程师 :  您好,从如下微软官方SQL Server安装说明来看,Windows Server 2003标准版确实不支持安装SQL Server 2005企业版。  
http://technet.microsoft.com/zh-cn/library/ms143506(v=sql.90).aspx  

当前查看您已经将服务器系统更换为2008。对于该问题给您带来的不便很抱歉。  
感谢您的问题反馈和对阿里云的信赖。  2014-12-29 18:35:29  
云服务器登录 云服务器设置
分享到
取消 提交回答
全部回答(12)
  • w李白
    2015-05-09 16:38:18
    Re使用阿里云ECS无法安装SQL2005系统的问题
    0 0
  • 河南seo
    2015-05-01 18:40:59
    Re使用阿里云ECS无法安装SQL2005系统的问题
    感谢分享!http://www.lichuangcheng.com
    0 0
  • 围观群众1
    2015-04-07 16:44:54
    回18楼兔子王的帖子
    我也遇到了,安装CD2直接没反应,等下用你的方法试试

    -------------------------

    回25楼北京亿网的帖子
    我已经找到问题原因了,是微软补丁问题。。。
    一开始和你想的一样,以为是阿里云镜像问题,然后我就用GHOST装了个企业版2003 R2,一开始测试都还挺顺利,以为解决了,然后等我装完所有需要的东西打完所有补丁再去装一次SQL2005,居然出现了和用阿里云提供的标准版系统一模一样的错误,这个就说明不是标准版或者企业版区别造成的问题了。
    而且我看到帖子里有人说以前可以,很可能就是微软最新的补丁造成,因为阿里云提供的镜像都会打上近期的补丁,而之所以自己在服务器或者其他VPS上没问题估计是因为这种情况下我们装的时候大多数没更新过update。。。
    我刚才试了下用阿里云提供的镜像手工卸载2014年所有的更新,然后就正常安装上了

    -------------------------

    回30楼北京亿网的帖子
    呵呵,这种说法也是醉了,什么叫这种测试是主观倾向?至少我找出了导致问题存在的原因,而你所谓的技术测试却连这么简单的一个问题都找不出来解决,还怪罪于阿里云,也是醉了,我可以很明确的和你说,这和阿里云的系统没半毛钱关系,自己装个2003 R2企业版,打完最新补丁,看看是不是有一样的问题?不要又说是微软的问题了吧?
    这种测试虽不是技术层面,但这种简单粗暴的排除法从逻辑上来说得出的结果是肯定正确的,至少比你的“技术手段”有效得多,如果你自己觉得不行,那就继续2008装2005。顺便说下,我安装后就立马打补丁测试有无问题,完完全全没有任何的问题正常使用,稳定使用至今哦→_→不要太纠结技术死脑筋。。。

    -------------------------

    回 40楼bjyw用户的帖子

    大哥没搞错人吧?你自己看下帖子上下文,我一没喷人二没骂人,我在这帖子里开始和别人讨论解决方法的而已,这北京亿网自己搞不定问题还在那边冷嘲热讽说别人解决方法错了,就他自己对,别人反驳几句还不行?然后他自己骂骂咧咧洋洋洒洒回了好几楼我又多回了点罢了。
    另外就和我的ID一样,我纯纯的围观群众,和这个北京亿网没任何关系,我根本不认识这货啊。。。只不过在查找解决方案的时候看到这个帖子中有解决方法才回的而已,你自己帖子上面翻回去看,前面全是别人在认真对问题原因讨论,而这北京亿网则是一味得解决不了就认为一定是阿里云问题,而且还不停质疑嘲讽其他网友的看法和观点。
    再说了你自己被北京亿网坑,这也能喷上我啊,虽然我快看不懂你到底是在喷我还是喷北京亿网了,我也是醉了,躺着也中枪。。。
    不过有一点我可以和你确定就是,哥们,这北京亿网不是什么好人,也绝对不是什么好商家,你要买阿里云,直接官网买呗,至于装SQL什么的,根本没啥技术含量的,自己百度一下完全可以装的,没必要付钱给这种坑用户钱的商家。(PS,再重申一遍,阿里云的WIN2003标准版完全可以正常安装SQL2005,我已经安装使用1年以上,随时可以截图打他脸,至于那阿里云客服什么的,你要知道,阿里云客服很多也都是雇佣的普通技术人员,甚至不是技术人员,要么本身技术方面也一般,只知道常见的系统配置维护等问题,要么WIN2003微软都放弃维护了,人家根本就懒得鸟这北京亿网死皮赖脸得问题,直接丢给他一个“没错,是我们WIN2003的问题,你去装WIN2008”的答复,说白了,就是应付下,这还能被这货拿来当结论,也是深深得醉了,结论是自己测试出来用事实说话,而不是阿里云说啥就啥,自己解决不了还坑客户的!)
    这帖就此打住吧

    0 0
  • 兔子王
    2015-04-06 04:54:55
    Re使用阿里云ECS无法安装SQL2005系统的问题
    偶尔看到这个帖子,不知道还有没有遇到这个问题的,阿里云安装sql2005,一般都卡在安装CD2上面,在这里我提供一下解决办法,希望能对各位有所帮助,首先在添加删除程序里卸载Microsoft sql server 安装程序支持文件(英语),然后下载sql2005 sp4的补丁,解压缩后找到hotfixsqlsupport/files下的生气了support.msi文件,执行安装,然后再进行CD2 的安装就没有问题了。如果有不明白的,可以加QQ:7025441,吉林省易城盛世网络科技有限公司。

    -------------------------

    回26楼围观群众1的帖子
    看来你比某些人更专业,呵呵,谢谢分享,我也用着更放心了些。
    0 0
  • qq78315851
    2015-03-18 22:35:50
    回16楼ftp4oss的帖子
    阿里云之前的windows 2003 32位的是可以正常安装sql2005的。
    最近的这个镜像windows2003 32位的确实不可以安装sql2005企业版。
    我反复测试了多台服务器,重装了N次系统。
    报错也的确是楼主反馈的情况。
    阿里云一句话就完事:系统是纯净的,未做任何限制。但是确实安装不了!

    答复工单的根本都没有做任何测试。
    0 0
  • 千鸟
    2015-01-21 08:54:36
    2014年初的ECS,win2008系统,安装的MSSQL2008运行正常
    0 0
  • 中国舞曲网
    2015-01-20 14:54:06
    Re使用阿里云ECS无法安装SQL2005系统的问题
    我安装SQL2000可以正常用,就是1433端口本地TELNET本地不通 外网也不通,安全策略不指派了。。。。不知道是不是镜像系统问题。。。头痛
    0 0
  • 拔刀斋
    2015-01-17 03:38:03
    Re使用阿里云ECS无法安装SQL2005系统的问题
    好坑啊,安装mysql和vsftpd都失败了,。。。是按着教程弄的啊,,,为什么为什么。。。求解。。。
        都不想用了。。。
    0 0
  • ftp4oss
    2014-12-27 17:12:19
    我的ECS上安装的是SQL 2005的企业版,已经稳定运行有1年多了~~~

    -------------------------

    回 12楼(北京亿网) 的帖子
    ECS是2003的系统~~~

    0 0
  • 云追溯
    2014-12-27 16:46:58
    Re使用阿里云ECS无法安装SQL2005系统的问题
    刚刚碰到这个问题,可以安装SQL2005 Express版管理工具,希望阿里云解决这个问题
    0 0
  • 北京亿网
    2014-12-06 20:26:42
    回楼主北京亿网的帖子
    感谢你的关注,以后有什么问题可以咨询我们北京亿网,由于给客户上了一台阿里云产品,深深体会到了客户的不容易,我们亲自沟通都不行,最后还是自己查出原因,投诉什么的是没用的,你自己生气还不如自己想办法,指不上,第三方公司一等一小天,并且真的问题他们也是处理不了,只有普通客户的问题才能解决估计,比如这次,一分钟就明白的事,万网和第三方弄四天,我们客户急了都,没办法我们通地不断检查测试,查清原因了.

    -------------------------

    Re使用阿里云ECS无法安装SQL2005系统的问题
    引用楼主北京亿网于2014-12-06 08:15发表的 使用阿里云ECS无法安装SQL2005系统的问题 :
    问题描述 : 在安装mssql2005时,安装CD1顺利完成,在安装CD2时无法进行,双击安装文件后自动关闭,无提示!怎么解决?

    看的日志提示是:
    事件 ID ( 11260 )的描述(在资源( MsiInstaller )中)无法找到。本地计算机可能没有必要的注册信息或消息 DLL 文件来从远程计算机显示消息。您可能可以使用 /AUXSOURCE= 标识来检索词描述;查看帮助和支持以了解详细信息。下列信息是事件的一部分: 产品: Microsoft SQL Server 安装程序支持文件(英语) -- 错误 1260。由于一个软件限制策略的阻止,Windows 无法打开此程序。要获取更多信息,请打开事件查看器或与系统管理员联系。

    ....... [url=http://bbs.aliyun.com/job.php?action=topost&tid=187191&pid=tpc][/url]

    服务态度还行,就是服务方式不好,回复你的售后基本可以讲不算是一名技术人员,他不这样说也没什么可说的了,不过有一点说的没错,你这边不急不投诉他真不给你重视起来呢,你说怪不怪!

    -------------------------

    Re使用阿里云ECS无法安装SQL2005系统的问题
    问题已经自行查明原因,阿里提供镜象问题,暂时还无法加其他版本镜象,只能更换系统.

    -------------------------

    回6楼云追溯的帖子
    好久没来阿里云论坛了,今天打开一看自己的贴子又跑首页了,你们就别指着给你解决什么,就一个弄清问题叫他们承认都要用我一个来月的时间,最后的结果是清楚原因,但不能给解决,只能逼着你换系统,所以别指望了,如果实在用不了,还是用我们的产品吧,还有代维服务,我们给客户代购的阿里云产品叫我们技术部操了不少心,要是我们的产品直接帮解决了,我这只能帮查出问题,叫人家解决,但后台没几个技术是专业的,全是叫第三方给查看,就算指出原因,也不会给解决,估计是反应不上去,没人重视,只要广告打的响,你们这些用不了的还不如新来的人多,不可能重视,大公司没办法!

    -------------------------

    回7楼ftp4oss的帖子
    你的企业版2005数据库是装在阿里云2003系统上的吗,要是装2008系统上的这种另类反搭配就别在这讲了,那不如直接装SQL2008了.这个贴子的前题时指2003系统通常搭配的2005数据库无法安装的问题.原因是阿里云没有提供专业的服务器版系统静象,这种不专业的系统来当服务器系统,也只能装个人用的精简的数据库2005,企业的装不了.

    -------------------------

    回8楼拔刀斋的帖子
    阿里云的技术支持仅限安装系统这部分,然后有什么问题安装什么他们也没个专业的技术来判断,只会告诉你支持,或是没限制,事实不是这样,因为他们提供的系统本身就有局限,等你问个半个月了也搞不了,他们换几个技术也搞不了时,会推荐你叫第三方服务,基本上所谓的第三方也没有几个专业的,提问一次两三天有个结果吧,建议没有技术力量的客户不要在折磨自己了,因为你搞什么想弄个对错都没有人帮你去判断!如果一定用阿里云可以联系我们代购,至少我们负责代维,不是他们后台不专业的技术说什么是什么,就是不给解决他也得承认我们查出的问题,到时你想退款也有依据.如果就是租了一个月也别退了,就当交学费了,直接在我们这买产品,我们可以代购阿里云,也有自己的产品,包维护,支持环境应用技术支持.

    -------------------------

    回9楼中国舞曲网的帖子
    SQL2000这个版本有点低了,几年前我们就不装这种环境了,没有试,是不是阿里系统静象问题也不好说,如果还是那个静象那就是有问题,虽然此前有一个用户和我说同样的静象版本在另一个区购买的高配置就可以安装,这个我没亲自看,所以也不确定他说的是不是真实的,总之吧,服务器系统应用服务器版系统才是专业的,用什么标准,,精简,就是能装上以后也会有各种各样的问题,不专业的表现,配套能装上的也全是一些精简的个人研究之用的数据库版本,所以从专业角度就是系统问题,从相对论上来说,装个个人研究之用的数据库2005我也可以给客户装上,但那是精简的,你懂的!

    -------------------------

    Re使用阿里云ECS无法安装SQL2005系统的问题
    好久没来了,今天来看发现自己的贴子又叫顶到首页了,看来好有后来人在受困扰,那就全回复一下吧,另外有一些看了广告就来买阿里云又不会用的,又不会装环境的亲们,来北京亿网寻求帮助吧,提供代维服务.

    -------------------------

    回7楼ftp4oss的帖子
    你要不是提供个截图我还真以为你装了个企业版,我贴子中似乎有讲过在我们遇到这个问题后,也有万网多名技术员测试安装无法成功,并且万网委托的第三方技术公司也未能安装成功,最后认同了我们的结论,他这个静象就不能装企业版2005,用一些方法装上后在以后使用和更新时会更多的麻烦,所以放下研究真的使用这样免强装上是不行的,但你这里还截了图,还安静的讲装上了还用了一年多,,为了不叫看我贴的其他用户叫你误导,本楼主在此有必要回复一下,你讲的可能是一个事实,但你截图的这个版本并不是企业版SQl2005,从你截图显示的版本号1399来看,似乎是开发版,并不是真正的企业版,所以和我讲的阿里云目前的提供的2003系统并不能完美安装SQL2005企业版不是同一个问题.看签名你还是级别: 工具与镜像服务商 ?那就向万网要求提供下服务器版2003静象吧,这样专业一些,能适合不同版SQL2005,就不会有这么多客户的各种问题了,我没有时间在建议这些.

    -------------------------

    回17楼数据佰度的帖子
    17楼看来是真的去安装测试了,看得出 是比较认真的一个人,你的测试是正确的,万网电话客服人员普遍技术水平是零,包括后台技术的回复也是相当不负责,这一点我早早有提出过,但建议是建议,人家还是那样,从你讲的看来他们还是在和客户不停的讲这句,系统工程纯净的,全可以装,看来这个含糊不负责的回答现在想想不是他们不清楚这样回答不负责,这样回签对销量有意义,一些客户就是因为这句回答就买了,买完装不了就郁闷去吧.另外你楼上16楼他没你认真,他装的根本也不是企业版,所以他的测试没意义,你的结论是正确的.

    -------------------------

    回19楼围观群众1的帖子
    只为了装上通过查看系统日志提示,通过结束进程,移队插件,直接用静象文件修复安装等多种方式都能完成安装过程,但这种安装并不是真的成功,特别是配套其他软件使用时,以后在更新升级时问题多多,这些最开始我们公司全有测试过,所以最后才有以上结论,阿里云这个2003系统并不是他们讲的那样可以装企业版2005,如果他们不能提供服务器版2003系统,大家就不要在浪费时间了.

    -------------------------

    回26楼围观群众1的帖子
    这个贴子这么久还有人围观,首先感谢大家的关注和支持!
    26楼看得出也是一个热爱技术和喜欢发现问题,研究问题,解决问的人,这很好!
    但关于微软的系统版本和数据库版本对应问题,官方版本的划分已经是一个答案了,如果全通用还划分版本做什么,这本不是一个值得讨论的事情,此问题其根本是源于我的客户在咨询阿里售后时得到的精典答复是:系统是纯净的,全可以装"有关这个说法建议可以直接咨询微软方面,本人不过多说明,只是对热爱技术的网友回下贴,感谢关注.

    你这种测试是有主观倾向的,什么也证明不了,服务器技术管理人员哪有不打补丁的呢,如果要把补丁移除才能装那本身就是个问题,为了解决一个问题而把一年的补丁移除来说明是补丁问题这相当的不可取,很危险的维护方式.补丁也是系统的一部分,并且不出意外你这种方式 装上了,在以后打补丁还会出问题,到时你来此贴报个道吧,如果只是为了能装上,方法很多,我的贴子中也有提到,但用户他租这个是用来使用的,不是一时研究之用,所以只有根本的解决方法才是真的解决,踏实的按微软的版本对应要求配置安装才是正道,其他全是取巧,如果就是暂时解决,以后服务器也是要升级补下的,如果微软某个补丁就是适于对应版本才可以时,那时才要换成对应版本吗,更何况叫服务商增加服务器版系统对客户是好事,对服务商来说也是更专业,难道租这个不是来当服务器吗

    -------------------------

    回29楼兔子王的帖子
    感谢围观,你这种租台机器挂QQ用的,是不需要装数据库的,所以你放不放心都没意义,更不会懂技术间讨论的那种乐趣,如果你的水平都可以来判断专业与否了,那会上网打字全是高级技术员了,如果你的乐趣就是用言语挑事,打个嗝都要说所处地气候环境不适合你生长,很不巧我向来以言语犀利 为自我评价。要不你开个贴我可以和你一样不知天高地厚的用敲字来PK下双方的神经反应系统灵敏度。所以不要在我的贴子上面发广告,还留个QQ,还网络公司,先不说你在我贴子下留广告这是一种不尊重,其次你那所谓的解决方式不是误人子弟吗,自己坑了不要急,不能坑了客户,给别人留后患.还某人某人的,如果没有建设性的技术方案要和大这交流的就收起你的广告和管好你地张嘴.

    -------------------------

    回 17楼(数据佰度) 的帖子
    这个人厚道,至少他清楚我发这个贴子在说什么和我的用意,这是广大用户对阿里方面要求提升服务的一种鞭策,阿里方面至少和我直接沟通的人员也很认可我讲的这一点,至少态度是友好的,并且我发这个贴子时离2003官方不在支持还有半年,有一天我们也要给客户最好的支持,这才是服务,现在我们自己都不用2003了,因为官方不支持了,这个是一个硬性依据!

    -------------------------

    回 29楼(兔子王) 的帖子
    对,这种人你得捧,给他勇气,叫他一直傻下去,一个版本对应问题官方都有说明的事,还搞的这么复杂,没人说镜象问题,我一直在说版本,要提供服务器版本,对大众客户来说,用标准版装去装企业版数据库就会碰到这样的问题,他们不是技术人员,你叫他们每个人和你一样去这样弄几天才成就了你的自尊心是吗,你那叫解决了是吗,过了半年你现在还这样想,那你真没救了,你看你已经把这位误导了。自己偶尔的一个测试原因尚不明确就拿 出来当论据了,很不负责任做为一个技术人员!

    -------------------------

    北京亿网感谢大家的关注,这个贴子很久了,今天上来结下贴的,欢迎大家交流,但希望发表技术类方面的言论时不要给其他人造成误导,否则我讲话可是很直接的叫你不舒服的,为了证明我不是恶意针对某人,在这里结贴时也给感谢一下阿里方面的回复,我今天 才上来看到,这对于个别人来讲,可能看了会感觉打脸,阿里人家不需要你的跪添,所以在讨论技术问题时至少不要在我面前硬装人,看下吧,那位硬说版本没半毛钱关系的那位,顺便说句这个贴子就结了,以后大家关注北京亿网新贴子,我们已经为用户提阿里美国,香港,国内的阿里云空间产品,新加坡的也要上线了,谢谢大家来使用,联系我们吧!

    下面是阿里云工程师对我们这个提问的回复,结贴了,大家以后不要在讨论了。
    售后工程师 :  您好,从如下微软官方SQL Server安装说明来看,Windows Server 2003标准版确实不支持安装SQL Server 2005企业版。
    http://technet.microsoft.com/zh-cn/library/ms143506(v=sql.90).aspx

    当前查看您已经将服务器系统更换为2008。对于该问题给您带来的不便很抱歉。
    感谢您的问题反馈和对阿里云的信赖。  2014-12-29 18:35:29

    -------------------------

    回 42楼(bjyw用户) 的帖子
    用户您好,请别激动,也不要生气了!首先要感谢你告诉我们的账号叫封停了,你不告诉我们都不知道!刚已经联系阿里解封了,那个版主我就不点名了,他自己发的帖子植入广告别人又不是看不出来,估计当这个版主就是为了自己发广告方便才申请的吧,但你自己方便也就算了,怎么还乱用权限了呢, 有点自知之明好不好,我们下边的客户草根站长多的事,全应可以来申请版主,哪轮得到你删贴和禁言的,有事你说事啊,直接封公司的账号你脑子是不是缺点什么?

    还有我这个帖子早就结贴了,那个小号上来骂骂咧咧的,某版主没见你一起封啊,用我们用户的话讲你是不是瞎?还有那个小号你也不要在这骂,我也理解你一万年解决了一个问题出来显摆下的心情,这类问题在技术部天天都有的事,我们都表示没什么可说的了,我都结贴了你怎么还没脸没皮的上来发上面的话?阿里工程师都回复,我都贴 出来了,告诉大家不要在讨论了,你看你把我们用户气的!在贴下你看看吧,无知喷人不要紧,但你也看明白人家讲什么你在喷啊,我在这里给大家讨福利的事,你在那折什么台呢,我们客户举的例子你要是看不懂,我给你举个吧:话说一个通道,客户人家就要正常的直接走过去,因为一直这样走,可你一定要来个左三步,右三步,退一步,进两步,搞的和过关一样,最后也能过去,或者叫用户记得这个口决每次也可以过去,你认为这个就不需要解决了是吧?问题是客户为什么要记这些,会这些呢,人家的软件又无问题,人家客户又不想聘个技术人员,如果说一次免费两次免费我们可以帮,但经常的重装我们没事就给处理这个问题吗?为什么不能一劳永逸?明白我发贴的意思了吗?还不理解我也没办法,我承认我嘴比较黑,但对客户这块不含糊,但你看客户有骂我的吗?

    下面是阿里云工程师对我们这个提问的回复,结贴了,大家以后不要在讨论了。
    售后工程师 :  您好,从如下微软官方SQL Server安装说明来看,Windows Server 2003标准版确实不支持安装SQL Server 2005企业版。
    http://technet.microsoft.com/zh-cn/library/ms143506(v=sql.90).aspx

    当前查看您已经将服务器系统更换为2008。对于该问题给您带来的不便很抱歉。
    感谢您的问题反馈和对阿里云的信赖。  2014-12-29 18:35:29


    看到了吧?看清了吗?可能有人会问,你知道这个原因为什么要发求助贴呢,为什么还讨论这么久呢?能这样问的只能说你没认真看我发的相关贴子,我在最开始联系阿里方面时就告诉是这个原因,要提供一个服务器版镜象就没问题了,但阿里后台客服坚持那句话“我们的系统没有问题,可以直接装你的那个企业版2005”并且客户自己也打电话问了,也是那样回答的!所以我们只能把处理记录和进程贴出来,叫客户也看到,最后客户也完全理解我们和阿里方面了不是吗?如果说我们是为了显摆什么技术,那这类问题每天给阿里发来10个贴子, 我们还得聘一个阿里论坛编辑了,所以这个贴子完全是因为用户要看,我们才发的!如果我们经常来,也不会叫某傻X版主封号都不知道了!
    0 0
  • ghoulich
    2014-12-06 08:54:34
    Re使用阿里云ECS无法安装SQL2005系统的问题
    第三方的镜像最好不要用。。。阿里云的客服总是先将用户推给第三方,实在不行了才自己处理,这样的服务态度很不好很不好!
    0 0
滑动查看更多
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

相似问题
最新问题