阿里云短信服务在本地发送成功,部署到阿里云服务器报错HMAC-SHA1 not supported.-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

阿里云短信服务在本地发送成功,部署到阿里云服务器报错HMAC-SHA1 not supported.

haaa 2017-08-24 09:52:15 4146

_

本地pom文件:

xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>

<groupId>com.adv.cn</groupId>
<artifactId>monitor</artifactId>
<version>0.0.1-SNAPSHOT</version>
<packaging>jar</packaging>

<name>monitor</name>
<url>http://maven.apache.org</url>

<properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>

<dependencies>
    <dependency>
        <groupId>junit</groupId>
        <artifactId>junit</artifactId>
        <version>3.8.1</version>
        <scope>test</scope>
    </dependency>
    <dependency>
        <groupId>com.aliyun</groupId>
        <artifactId>aliyun-java-sdk-core</artifactId>
        <version>3.2.3</version>
        <!-- <scope>system</scope> <systemPath>${project.basedir}/lib/aliyun-java-sdk-core-3.2.3.jar</systemPath> -->
    </dependency>
    <dependency>
        <groupId>com.aliyun</groupId>
        <artifactId>aliyun-java-sdk-dysmsapi</artifactId>
        <version>1.0.0-SANPSHOT</version>
        <scope>system</scope>
        <systemPath>${project.basedir}/lib/aliyun-java-sdk-dysmsapi-1.0.0-SANPSHOT.jar</systemPath>
    </dependency>
</dependencies>
<build>
    <finalName>monitor</finalName>
    <!-- <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
                <encoding>UTF-8</encoding>
                <compilerArguments>
                    <extdirs>D:\gxy\monitor\lib</extdirs>
                </compilerArguments>
            </configuration>
        </plugin>
        
            <plugin>  
    <groupId>org.apache.maven.plugins</groupId>  
    <artifactId>maven-assembly-plugin</artifactId>  
    <version>2.3</version>  
    <configuration>  
        <appendAssemblyId>false</appendAssemblyId>  
        <descriptorRefs>  
            <descriptorRef>jar-with-dependencies</descriptorRef>  
        </descriptorRefs>  
        <archive>  
            <manifest>  
                <mainClass>com.cn.monitor.SmsDemo</mainClass>  
            </manifest>  
        </archive>  
    </configuration>  
    <executions>  
        <execution>  
            <id>make-assembly</id>  
            <phase>package</phase>  
            <goals>  
                <goal>assembly</goal>  
            </goals>  
        </execution>  
    </executions>  
</plugin>   -->

    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-jar-plugin</artifactId>
            <configuration>
                <archive>
                    <manifest>
                        <addClasspath>true</addClasspath>
                        <classpathPrefix>lib/</classpathPrefix>
                        <mainClass>com.cn.monitor.SmsDemo</mainClass>
                    </manifest>
                </archive>
            </configuration>
        </plugin>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-dependency-plugin</artifactId>
            <executions>
                <execution>
                    <id>copy</id>
                    <phase>package</phase>
                    <goals>
                        <goal>copy-dependencies</goal>
                    </goals>
                    <configuration>
                        <outputDirectory>${project.build.directory}/lib</outputDirectory>
                    </configuration>
                </execution>
            </executions>
        </plugin>
    </plugins>

</build>

分享到
取消 提交回答
全部回答(4)
  • 1826731670543011
    2019-07-17 21:31:26

    解释问题
    1、阿里云的接口是采用hamc-sha1算法进行签名计算,以确保接口调用的安全性。
    2、java和C#都调整了hamc-sha1算法的实现路径。
    解决问题java:
    一般发生在jdk8上,部分jdk7也有
    第一步,需要核实/jre/lib/ext下是否有sunjce_provider.jar
    第二步、核对java启动环境是否加载了“sunjce_provider.jar”(直接将sunjce_provider.jar复制到工程jar目录libs亦可实现强行加载)
    即 cp /soft/jdk1.X.X_XX/jre/lib/ext/sunjce_provider.jar /../api_demo/alicom-dysms-api/libs/
    附网上帮助
    Copying sunjce_provider.jar from $JAVA_HOME/jre/lib/ext to the lib directory of the container.
    Adding the following line to my code:
    java.security.Security.addProvider(new com.sun.crypto.provider.SunJCE());

    解决问题C#版:
    发生在从net2.0net3.5net4.0 升级到core2.0时候。
    1、命名空间都发生了变化,不能使用参数实例化对象。
    即将Aliyun.Acs.Core.Auth.ShaHmac1的46行 KeyedHashAlgorithm.Create("HMACSHA1")改为 new HMACSHA1()。
    https://github.com/aliyun/aliyun-openapi-net-sdk/blob/master/aliyun-net-sdk-core/Auth/ShaHmac1.cs
    using (var algorithm = new HMACSHA1())// KeyedHashAlgorithm.Create("HMACSHA1"))

    0 0
  • 1174884031645045
    2019-07-17 21:31:26

    jdk的问题 看下配置环境的jdk ext目录下有sunjce_provider.jar就可以 jre的话好像都没有

    0 0
  • huan.deng
    2019-07-17 21:31:26

    请问解决了没有,在开发环境把java jdk1.7换成1.8就出现这个问题HMAC-SHA1 not supported.

    0 0
  • 51干警网
    2019-07-17 21:31:26

    建议工单吧。

    0 0
添加回答
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章