ZZULIOJ-1059,最高分(Python)

简介: ZZULIOJ-1059,最高分(Python)

题目描述:


输入一批学生的成绩(整数),输出最高分。  


输入:


输入包含多个非负整数和一个负整数。该负数不作为有效成绩,只表示输入结束。  


输出:



输出一个整数,即最高分。单独占一行。  


样例输入:


7 6 5 9 2 -1


样例输出:


9


程序代码:


a=input().split()
k=maxx=0
while True :
            x=int(a[k])
            if x<0 :
                        break
            if maxx<x :
                        maxx=x
            k+=1
print(maxx)
相关文章
|
Python
ZZULIOJ-1009,求平均分(Python)
ZZULIOJ-1009,求平均分(Python)
|
Python
ZZULIOJ-1048,阶乘表(Python)
ZZULIOJ-1048,阶乘表(Python)
|
机器学习/深度学习 Python
ZZULIOJ-1089,阶乘的最高位(Python)
ZZULIOJ-1089,阶乘的最高位(Python)
|
Python
ZZULIOJ-1051,平方根的和(Python)
ZZULIOJ-1051,平方根的和(Python)
|
Python
ZZULIOJ-1006,求等差数列的和(Python)
ZZULIOJ-1006,求等差数列的和(Python)
|
Python
ZZULIOJ-1062,最大公约数(Python)
ZZULIOJ-1062,最大公约数(Python)
|
Python
ZZULIOJ-1007,鸡兔同笼(Python)
ZZULIOJ-1007,鸡兔同笼(Python)
|
Python
ZZULIOJ-1057,素数判定(Python)
ZZULIOJ-1057,素数判定(Python)
|
Python
ZZULIOJ-1036,某年某月有多少天(Python)
ZZULIOJ-1036,某年某月有多少天(Python)
|
Python
ZZULIOJ-1043,最大值(Python)
ZZULIOJ-1043,最大值(Python)