ZOJ-3869,Ace of Aces(简单题)

简介: ZOJ-3869,Ace of Aces(简单题)

Problem Description:


There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".


After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.


Please write program to help TSAB determine who will be the "Ace of Aces".


Input:


There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:


The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).


Output:


For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.  


Sample Input:


3


5


2 2 2 1 1


5 1 1 2 2 3


1


998


Sample Output:


2


Nobody


998


AC Code:


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1001
int a[N],num[N];
int main()
{
  int t,n;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(num,0,sizeof(num));//标记数组清零 
    for(int i=0;i<n;i++)
    {
      scanf("%d",&a[i]);
      num[a[i]]++;//每个数出现一次就加1 
    }
    int max1=0,max2=0,x=0;
    for(int i=0;i<N;i++)
    {
      if(max1<num[i])//第一遍遍历数组,查找到出现次数最多的那个数 
      {
        max1=num[i];//赋值 
        x=i;//对应下标赋给x 
      }
    }
    for(int i=0;i<N;i++)//第二次遍历数组,是为了查重 
    {
      if(max2<num[i]&&i!=x)//两个下标不能相同 
      {
        max2=num[i];//赋值 
      }
    }
    if(max1==max2)//如果两个数出现次数相同 
      printf("Nobody\n");
    else
      printf("%d\n",x);
  }
  return 0;
}


相关文章
|
7月前
|
运维 架构师 Linux
2024年阿里云ACE复习计划
作者目前已考取阿里云的ACP,可以说对阿里云的产品有了基础的了解,出于个人能力规划,还是计划继续备考ACE考试,但是重点不一定是突出在考试上,而是希望通过学习的过程能够查漏补缺,强化自己的云计算架构设计和实践能力,以及对复杂业务场景的解决能力。撰写本系列文的主要目的在于记录从零起步直至全面备战ACE的心路历程,这既是对未来自己的一个珍贵回顾,也是向有志于此道的同行者分享这一路上所积累的宝贵经验和实战心得,期待我们都能在回望时,清晰看见这段自我蜕变和成长的轨迹。
|
机器学习/深度学习 人工智能 算法
ABB PQF4-3 TAS.580.0600G00 V01 3BSE050090R20 PFEA111-20
ABB PQF4-3 TAS.580.0600G00 V01 3BSE050090R20 PFEA111-20
61 0
CF414B Mashmokh and ACM
CF414B Mashmokh and ACM
83 0
ABB PP846 3BSE042238R1 基于电子管的技术被点接触晶体管
ABB PP846 3BSE042238R1 基于电子管的技术被点接触晶体管
75 0
ABB PP846 3BSE042238R1 基于电子管的技术被点接触晶体管
|
容器
阿里云ACE 你知道多少?
看到ACE,相信有很多人想到的知道的还是几年前的:云引擎ACE不过现在它已经:http://ace.console.aliyun.com/ace.html ACE已经完成了使命。 如果您正在寻找类似的解决方案,或许您会有兴趣尝试阿里云上的弹性web托管和容器服务。
3781 1
|
机器学习/深度学习
|
人工智能 BI 应用服务中间件

热门文章

最新文章