POJ-3278,Catch That Cow(BFS)

简介: POJ-3278,Catch That Cow(BFS)

Description:


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.


* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.


If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?


Input:


Line 1: Two space-separated integers: N and K


Output:


Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.


Sample Input:


5 17


Sample Output:


4


Hint:


The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题目大意:


FJ要抓奶牛。

      开始输入N(FJ的位置)K(奶牛的位置)。

      FJ有三种移动方法:1、向前走一步,耗时一分钟。

                                       2、向后走一步,耗时一分钟。

                                       3、向前移动到当前位置的两倍N*2,耗时一分钟。

      问FJ抓到奶牛的最少时间。PS:奶牛是不会动的。


思路:1、如果FJ不在奶牛后面,那么他只有一步步往后移动到奶牛位置了,即N>=K时,输出N-K即可。


          2、否则bfs+队列查找


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 100001
bool vis[maxn];
int step[maxn];
queue<int> q;
int bfs(int n,int k)
{
  int head,tail;
  q.push(n);
  step[n]=0;
  vis[n]=true;
  while(!q.empty())
  {
    head=q.front();
    q.pop();
    for(int i=0;i<3;i++)
    {
      if(i==0)
        tail=head-1;
      else if(i==1)
        tail=head+1;
      else
        tail=head*2;
      if(tail<0||tail>maxn)
        continue;
      if(!vis[tail])
      {
        q.push(tail);
        step[tail]=step[head]+1;
        vis[tail]=true;
      }
      if(tail==k)
        return step[tail];
    }
  }
}
int main()
{
  int n,k;
  while(cin>>n>>k)
  {
    memset(step,0,sizeof(step));
    memset(vis,false,sizeof(vis));
    while(!q.empty())
      q.pop();
    if(n>=k)
      cout<<n-k<<endl;
    else
      cout<<bfs(n,k)<<endl;
  }
  return 0;
}


相关文章
|
人工智能
poj 2299 Ultra-QuickSort 求逆序数 树状数组解法
所谓离散化,我们的了解就是对原数组排序,然后用所在位置的下标代替原数,这样我们就可以把数据范围缩小到1-500000,这个数组是开的下的。
42 0
|
C++
poj 2182 Lost Cows(树状数组)
FJ有n头牛,现在它们排成一排,每一头牛都有一个不同的编号(1-n),现在知道从第二头牛开始每头牛左边比自己编号小的牛的数目,让你确定每头牛的编号。
40 0
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
HDOJ/HDU 1242 Rescue(经典BFS深搜-优先队列)
HDOJ/HDU 1242 Rescue(经典BFS深搜-优先队列)
108 0