HDU-1240,Asteroids!(BFS)

简介: HDU-1240,Asteroids!(BFS)

Problem Description:


You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.


Input:


Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.


A single data set has 5 components:


Start line - A single line, "START N", where 1 <= N <= 10.


Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:


'O' - (the letter "oh") Empty space


'X' - (upper-case) Asteroid present


Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.


Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.


End line - A single line, "END"


The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.


The first coordinate in a set indicates the column. Left column = 0.


The second coordinate in a set indicates the row. Top row = 0.


The third coordinate in a set indicates the slice. First slice = 0.


Both the Starting Position and the Target Position will be in empty space.


Output:


For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.


A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.


A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input:


START 1


O


0 0 0


0 0 0


END


START 3


XXX


XXX


XXX


OOO


OOO


OOO


XXX


XXX


XXX


0 0 1


2 2 1


END


START 5


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


XXXXX


XXXXX


XXXXX


XXXXX


XXXXX


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


OOOOO


0 0 0


4 4 4


END


Sample Output:


1 0


3 4


NO ROUTE


解题思路:


这道题与胜利大逃亡相似,一共有六个方向,也是一个三维的BFS,进行好细节的判断就可以了!


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
  int x,y,z,step;
};
char str[11],map[101][101][101];
int n,sx,sy,sz,ex,ey,ez,vis[101][101][101];
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
void bfs()
{
  int i,ans,flag=0;
  queue<node> q;
  node p,m;
  p.x=sx;
  p.y=sy;
  p.z=sz;
  p.step=0;
  q.push(p);
  vis[sx][sy][sz]=1;
  map[sx][sy][sz]='X';
  map[ex][ey][ez]='O';
  while(!q.empty())
  {
    p=q.front();
    q.pop();
    if(p.x==ex&&p.y==ey&&p.z==ez)
    {
      flag=1;
      ans=p.step;
      break;
    }
    for(i=0;i<6;i++)
    {
      m.x=p.x+dir[i][0];
      m.y=p.y+dir[i][1];
      m.z=p.z+dir[i][2];
      if(m.x>=0&&m.x<n&&m.y>=0&&m.y<n&&m.z>=0&&m.z<n
        &&!vis[m.x][m.y][m.z]&&map[m.x][m.y][m.z]=='O')
      {
        m.step=p.step+1;
        map[m.x][m.y][m.z]='X';
        vis[m.x][m.y][m.z]=1;
        q.push(m);  
      }
    }
  }
  if(flag)
    cout<<n<<" "<<ans<<endl;
  else
    cout<<"NO ROUTE"<<endl;
}
int main()
{
  while(scanf("%s%d",str,&n)!=EOF)
  {
    memset(vis,0,sizeof(vis));
    for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
        for(int k=0;k<n;k++)
          cin>>map[i][j][k];
    cin>>sx>>sy>>sz>>ex>>ey>>ez;
    cin>>str;
    bfs();
  }
  return 0;
}

 


相关文章
|
6月前
|
Java
hdu-1869-六度分离(dijkstra)
hdu-1869-六度分离(dijkstra)
38 0
|
6月前
|
Java
hdu-2544-最短路(SPFA)
hdu-2544-最短路(SPFA)
32 0
|
6月前
|
Java
hdu-1874-畅通工程续(dijkstra + SPFA )
hdu-1874-畅通工程续(dijkstra + SPFA )
35 0
HDU-1874,畅通工程续(Floyd最短路)
HDU-1874,畅通工程续(Floyd最短路)
|
并行计算 算法 Java
HDU 1874 畅通工程续【Floyd算法实现】
畅通工程续 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 53806    Accepted Submission(s): 20092 Problem Description 某省自从实行了很多年的畅通工程计划后,终于修建了很多路。
1086 0
|
算法 JavaScript
【UVA 10307 Killing Aliens in Borg Maze】最小生成树, kruscal, bfs
题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=20846 POJ 3026是同样的题,但是内存要求比较严格,并是没有过。
1356 0