HDU-1071,The area(求面积水题)

简介: HDU-1071,The area(求面积水题)

Problem Description:


Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?


Note: The point P1 in the picture is the vertex of the parabola.

网络异常,图片无法展示
|




Input:


The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).


Output:


For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.


Sample Input:


2


5.000000 5.000000


0.000000 0.000000


10.000000 0.000000


10.000000 10.000000


1.000000 1.000000


14.000000 8.222222


Sample Output:


33.33


40.69


Hint


For float may be not accurate enough, please use double instead of float.


程序代码:


#include<stdio.h>
int main()
{
  double x1,x2,x3,y1,y2,y3;
  double k,t,a,b,c,s1,s2;
  int n;
  while(scanf("%d",&n)!=EOF)
  {
    while(n--)
    {
      scanf("%lf %lf %lf %lf %lf %lf",&x1,
        &y1,&x2,&y2,&x3,&y3);
      k=(y3-y2)/(x3-x2);
      t=y3-k*x3;
      a=(y2-y1)/((x1-x2)*(x1-x2));
      b=-2*x1*a;
      c=y1-a*x1*x1-b*x1;
      s1=1.0/3*a*x2*x2*x2+1.0/2*(b-k)*x2*x2+(c-t)*x2;
      s2=1.0/3*a*x3*x3*x3+1.0/2*(b-k)*x3*x3+(c-t)*x3;
      printf("%.2f\n",s2-s1);
    }
  }
  return 0;
}



相关文章
|
7月前
|
机器学习/深度学习
N皇后问题(HDU—2253)
N皇后问题(HDU—2253)
hdu 1196 Lowest Bit(水题)
hdu 1196 Lowest Bit(水题)
44 0
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
82 0
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
|
测试技术
【CCCC】L3-022 地铁一日游 (30分),floyd+大模拟
【CCCC】L3-022 地铁一日游 (30分),floyd+大模拟
266 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ(HDU) 2088 Box of Bricks(平均值)
93 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
|
测试技术
HDOJ(HDU) 1859 最小长方形(水题、、)
HDOJ(HDU) 1859 最小长方形(水题、、)
81 0
|
机器学习/深度学习
HDOJ(HDU) 2083 简易版之最短距离(中位数)
HDOJ(HDU) 2083 简易版之最短距离(中位数)
143 0