PKU 3624 Charm Bracelet

简介: 本文主要讲背包入门题

Charm Bracelet

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 16


Problem Description


Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).


Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.



Input


* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di



Output


* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints



Sample Input

 


   4 6

1 4

2 6

3 12

2 7

 


Sample Output

 


   23

 


Source

PKU

 

01背包入门题


#include<stdio.h>
#include<string.h>
int f[13333];
int wi[4444];
int di[4444];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int m,n;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&wi[i],&di[i]);
        memset(f,0,sizeof(f));
        for(i=0;i<n;i++)
        {
            for(j=m;j>=wi[i];j--)
            {
                f[j]=max(f[j],f[j-wi[i]]+di[i]);
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}
相关文章
|
9月前
|
JavaScript
鬼火起~为什么报错[Vue warn]: Avoid mutating a prop directly since the value will be overwritten whenever the
鬼火起~为什么报错[Vue warn]: Avoid mutating a prop directly since the value will be overwritten whenever the
|
6月前
|
开发工具 git
Stylelint——Unexpected unknown pseudo-class selector ":deep" selector-pseudo-class-no-unknown
新项目制定规范接入了stylelint,并通过husky在git提交时去触发检测修复,使用`:deep()`的时候却发现了报错;
232 1
|
9月前
|
小程序 JavaScript
Avoid mutating a prop directly since the value will be overwritten whenever the parent comp
Avoid mutating a prop directly since the value will be overwritten whenever the parent comp
|
Kubernetes Docker 容器
Kubernetes分享-ImagePullBackOff Error的trouble shooting
Kubernetes分享-ImagePullBackOff Error的trouble shooting
325 0
|
Android开发
【Solve】InnerClass annotations are missing corresponding EnclosingMember annotations. Such InnerClass annotations are ignored
【Solve】InnerClass annotations are missing corresponding EnclosingMember annotations. Such InnerClass annotations are ignored
143 0
【Solve】InnerClass annotations are missing corresponding EnclosingMember annotations. Such InnerClass annotations are ignored
|
机器学习/深度学习
AtCoder Beginner Contest 215 E - Chain Contestant (状压dp)
AtCoder Beginner Contest 215 E - Chain Contestant (状压dp)
133 0
ZOJ - Problem Set - 3960 What Kind of Friends Are You?
ZOJ - Problem Set - 3960 What Kind of Friends Are You?
97 0
ZOJ - Problem Set - 3960 What Kind of Friends Are You?
PKU 3624 Charm Bracelet
本文主要讲背包入门题
109 0
|
JavaScript
Avoid mutating a prop directly since the value will be overwritten whenever the parent component re-
Avoid mutating a prop directly since the value will be overwritten whenever the parent component re-
Avoid mutating a prop directly since the value will be overwritten whenever the parent component re-