PKU 3624 Charm Bracelet

简介: 本文主要讲背包入门题

Charm Bracelet

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 16


Problem Description


Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).


Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.



Input


* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di



Output


* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints



Sample Input

 


   4 6

1 4

2 6

3 12

2 7

 


Sample Output

 


   23

 


Source

PKU


01背包入门题

#include<stdio.h>
#include<string.h>
int f[13333];
int wi[4444];
int di[4444];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int m,n;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&wi[i],&di[i]);
        memset(f,0,sizeof(f));
        for(i=0;i<n;i++)
        {
            for(j=m;j>=wi[i];j--)
            {
                f[j]=max(f[j],f[j-wi[i]]+di[i]);
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}

 


相关文章
|
Kubernetes Docker 容器
Kubernetes分享-ImagePullBackOff Error的trouble shooting
Kubernetes分享-ImagePullBackOff Error的trouble shooting
298 0
PKU 3624 Charm Bracelet
本文主要讲背包入门题
PAT (Advanced Level) Practice - 1080 Graduate Admission(30 分)
PAT (Advanced Level) Practice - 1080 Graduate Admission(30 分)
108 0
|
人工智能 BI 容器
|
Go 数据中心
Terraform Alicloud provider开发之Trouble Shooting
实现OTS resource `alicloud_ots_table`的表创建编排后,完成了[Terraform Alicloud provider开发入门](https://www.atatech.org/articles/104556),发现表更新删除还有不少坑。 # Terraform provider怎么debug ``` export TF_LOG=DEBUG ``` 设置后,
156 0