HDOJ(HDU) 2162 Add ‘em(求和)

简介: HDOJ(HDU) 2162 Add ‘em(求和)

Problem Description

Write a program to determine the summation of several sets of integers.


Input

The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.


Output

A single line of output should be generated for each set of integers. The line should have format shown below.


Sample Input

4

-1

3

1

1

2

19

17

5

-645

952

-1488

-5456

-9342

-1


Sample Output

Sum of #1 is 4

Sum of #2 is 36

Sum of #3 is -15979


简单题,就是求和。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t=0;
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==-1){
                break;
            }
            long  sum=0;
            for(int i=0;i<n;i++){
                long a = sc.nextLong();
                sum+=a;
            }
            System.out.println("Sum of #"+(++t)+" is "+sum);
        }
    }
}
目录
相关文章
|
7月前
|
机器学习/深度学习 人工智能 vr&ar
A. Mocha and Math(codeforces#738(div2))
A. Mocha and Math(codeforces#738(div2))
32 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
76 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ(HDU) 2088 Box of Bricks(平均值)
66 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ(HDU) 2143 box(简单的多次判断-用的卫条件)
HDOJ(HDU) 2143 box(简单的多次判断-用的卫条件)
68 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
215 0
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
87 0
|
Go
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
87 0
|
人工智能
HDOJ/HDU 2710 Max Factor(素数快速筛选~)
HDOJ/HDU 2710 Max Factor(素数快速筛选~)
80 0
HDOJ 1391 Number Steps(打表DP)
HDOJ 1391 Number Steps(打表DP)
98 0
HDOJ 1391 Number Steps(打表DP)