HDOJ(HDU) 2162 Add ‘em(求和)

简介: HDOJ(HDU) 2162 Add ‘em(求和)

Problem Description

Write a program to determine the summation of several sets of integers.


Input

The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.


Output

A single line of output should be generated for each set of integers. The line should have format shown below.


Sample Input

4

-1

3

1

1

2

19

17

5

-645

952

-1488

-5456

-9342

-1


Sample Output

Sum of #1 is 4

Sum of #2 is 36

Sum of #3 is -15979


简单题,就是求和。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t=0;
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==-1){
                break;
            }
            long  sum=0;
            for(int i=0;i<n;i++){
                long a = sc.nextLong();
                sum+=a;
            }
            System.out.println("Sum of #"+(++t)+" is "+sum);
        }
    }
}
目录
相关文章
Light oj 1080 - Binary Simulation(树状数组区间更新点查询)
有一字符串只包含0和1,然后又m组操作,I L R是将从L到R的字符进行翻转操作0变为1、1变为0,Q x表示询问第x的字符。
49 0
洛谷P1216-[USACO1.5][IOI1994]数字三角形 Number Triangles(DP)
洛谷P1216-[USACO1.5][IOI1994]数字三角形 Number Triangles(DP)
洛谷P1216-[USACO1.5][IOI1994]数字三角形 Number Triangles(DP)
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ(HDU) 2088 Box of Bricks(平均值)
99 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
108 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
248 0
【1048】Find Coins (25 分)
【1048】Find Coins (25 分) 【1048】Find Coins (25 分)
133 0