HDOJ(HDU) 1587 Flowers(水、、)

简介: HDOJ(HDU) 1587 Flowers(水、、)

Problem Description

As you know, Gardon trid hard for his love-letter, and now he’s spending too much time on choosing flowers for Angel.

When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers.

“How can I choose!” Gardon shouted out.

Finally, Gardon– a no-EQ man decided to buy flowers as many as possible.

Can you compute how many flowers Gardon can buy at most?


Input

Input have serveral test cases. Each case has two lines.

The first line contains two integers: N and M. M means how much money Gardon have.

N integers following, means the prices of differnt flowers.


Output

For each case, print how many flowers Gardon can buy at most.

You may firmly assume the number of each kind of flower is enough.


Sample Input

2 5

2 3


Sample Output

2


HintHint

Gardon can buy 5=2+3,at most 2 flower, but he cannot buy 3 flower with 5 yuan.


大概题意:

输入m n

再输入m种花的价格

就是你有n元钱,需要买最多的花,问最多能买多少朵花!

一种花你可以买很多朵!!!

所以,只要找到最低价格的花就可以了。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int a = sc.nextInt();
            int b = sc.nextInt();
            int min = sc.nextInt();
            a--;
            int t;
            while(a-->0){
                t = sc.nextInt();
                if(t<min){
                    min=t;
                }
            }
            System.out.println(b/min);
        }
    }
}
目录
相关文章
|
7月前
|
Java 测试技术
hdu 1229 还是A+B(水)
hdu 1229 还是A+B(水)
31 0
|
7月前
|
Java
hdu 1219(水)
hdu 1219(水)
21 0
HDOJ/HDU 2560 Buildings(嗯~水题)
HDOJ/HDU 2560 Buildings(嗯~水题)
103 0
HDOJ/HDU 2560 Buildings(嗯~水题)
HDOJ(HDU) 1570 A C
HDOJ(HDU) 1570 A C
86 0
HDOJ(HDU) 1570 A C
HDOJ(HDU) 2500 做一个正气的杭电人(水~)
HDOJ(HDU) 2500 做一个正气的杭电人(水~)
105 0
HDOJ/HDU 2551 竹青遍野(打表~)
HDOJ/HDU 2551 竹青遍野(打表~)
95 0
HDOJ 1302(UVa 573) The Snail(蜗牛爬井)
HDOJ 1302(UVa 573) The Snail(蜗牛爬井)
123 0
HDOJ(HDU) 1465 不容易系列之一(错排)
HDOJ(HDU) 1465 不容易系列之一(错排)
74 0
|
算法 C++
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
95 0
HDOJ(HDU) 2520 我是菜鸟,我怕谁(等差数列)
HDOJ(HDU) 2520 我是菜鸟,我怕谁(等差数列)
99 0