HDOJ 1019 Least Common Multiple(最小公倍数问题)

简介: HDOJ 1019 Least Common Multiple(最小公倍数问题)

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1


Sample Output

105

10296

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            int a[] = new int[n];
            for(int i=0;i<n;i++){
                a[i] = sc.nextInt();
            }
            int k = a[0];
            for(int i=1;i<n;i++){
                int b = a[i];
                if(k>b){
                    b=b^k;
                    k=b^k;
                    b=b^k;
                }
                k=su(b,k,mod(b,k));
            }
            System.out.println(k);
        }
    }
    //最小公倍数。
    private static int su(int b, int k, int mod) {
        return k*(b/mod);
    }
    //求最大公约数,辗转相除法。b>k
    private static int mod(int b, int k) {
        while(k>0){
            int m = b%k;
            b=k;
            k=m;
        }
        return b;
    }
}
目录
相关文章
|
3月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
15 0
|
6月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
18 0
|
7月前
codeforces 344B - Simple Molecules
题意就是给出3个原子的化学价,然后组成一个分子,要保证这个分子是稳定的,如果你还记得高中化学知识的话这个很容易理解,然后让你求出1-2 2-3 1-3 号原子之间有几条键, 这里我分别用ta tb tc 表示, 用数学的方法表示出来的话就是a = tc + tb; b = ta+tc; c = ta + tb;可能有多种情况,只要输出一种即可。
21 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
99 0
HDOJ1019Least Common Multiple
HDOJ1019Least Common Multiple
76 0
HDOJ(HDU) 1678 Shopaholic
HDOJ(HDU) 1678 Shopaholic
88 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
76 0
|
算法
HDOJ 1202 The calculation of GPA
HDOJ 1202 The calculation of GPA
73 0
|
Go
HDOJ 1012 u Calculate e
HDOJ 1012 u Calculate e
91 0
HDOJ 1012 u Calculate e