HDOJ1019Least Common Multiple

简介: HDOJ1019Least Common Multiple

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1


Sample Output

105

10296


也就是求最小公倍数

/**题意:
求输入的所有数最小公倍数。
思路:
先用 欧几里德定理
求两个数的最小公倍数,所得的公倍数再与下一个数求最小公倍数。
**/
#include <stdio.h>
#include <stdlib.h>
int gcd(int a,int b)//欧几里德求最大公约数
{
    if(b==0) return a;
    return gcd(b,a%b);
}
int main()
{
    int t,n,m,i,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        a=m;
        for(i=1;i<n;i++)
        {
            scanf("%d",&m);
            if(a<m)
            {
                b=a;a=m;m=b;
            }
            a=a/gcd(a,m)*m;//最小公倍数=两数之积/最大公约数
        }
        printf("%d\n",a);
    }
    return 0;
}
目录
相关文章
|
6月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
29 0
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
31 0
codeforces 344B - Simple Molecules
题意就是给出3个原子的化学价,然后组成一个分子,要保证这个分子是稳定的,如果你还记得高中化学知识的话这个很容易理解,然后让你求出1-2 2-3 1-3 号原子之间有几条键, 这里我分别用ta tb tc 表示, 用数学的方法表示出来的话就是a = tc + tb; b = ta+tc; c = ta + tb;可能有多种情况,只要输出一种即可。
41 0
HDOJ 1019 Least Common Multiple(最小公倍数问题)
HDOJ 1019 Least Common Multiple(最小公倍数问题)
95 0
|
算法
HDOJ 1202 The calculation of GPA
HDOJ 1202 The calculation of GPA
117 0
|
机器学习/深度学习 计算机视觉
成功解决This module was deprecated in version 0.18 in favor of the model_selection module into which all
成功解决This module was deprecated in version 0.18 in favor of the model_selection module into which all