HDOJ 2053 Switch Game

简介: HDOJ 2053 Switch Game

Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).


Input

Each test case contains only a number n ( 0< n < = 10^5) in a line.


Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).


Sample Input

1

5


Sample Output

1

0


Hinthint


Consider the second test case:


The initial condition : 0 0 0 0 0 …

After the first operation : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation : 1 0 0 1 0 …


The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.


思路:

说下题目大意吧,

先把这些灯标上号,1 2 3 4 5 6 7 8 ……无穷

首先全是关的,也就是全是0

第一次操作 ,标号是1的倍数,全都变成相反的状态,也就是全变成1.。

第二次操作 ,标号是2的倍数,全都变成相反的状态,你可以看下,2 4 6……变成了0.。。

第三次操作 ,标号是3的倍数,全都变成相反的状态,你可以看下,3 6 9……


他问你 N 号台灯最后 变成了 什么状态,

例如 1号灯,最后变成了1,不管多少次操作都是1.。

例如 5号灯 最后变成了0,不管多少次操作都是0.。


当操作次数大于N的时候 N的状态就不会改变了,因为N不会是M(M>N)的倍数。。


本题思路很简单就是求n有几个约数(包括1和自身)如果有奇数个约数,变奇数次,结果也就是1;否则为0

import java.util.Scanner;
public class Main {
//  static boolean[] islight = new boolean[100002];
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while (sc.hasNext()) {
            int n = sc.nextInt();
//          for(int i=1;i<=n;i++){
//              islight[i] = false;
//          }
//          
//          for (int i = 1; i <= n; i++) {
//              for (int j = 1; j <= n; j++) {
//                  if(j%i==0){
//                      islight[j] = !islight[j];
//                  }
//              }
//          }
//          
//          if(islight[n]){
//              System.out.println("1");
//          }else{
//              System.out.println("0");
//          }
//          超时
            int k =0;
            for(int i=1;i<=n;i++){
                if(n%i==0){
                    k++;
                }
            }
            if(k%2==0){
                System.out.println("0");
            }else{
                System.out.println("1");
            }
        }
    }
}
目录
相关文章
|
2月前
|
编译器
if-else对比switch-case
`if-else`和 `switch-case`是两种常用的控制流语句,各有优缺点和适用场景。`if-else`语句灵活性高,适用于复杂的条件判断;而 `switch-case`语句结构清晰,适用于处理固定的离散值。在实际应用中,根据具体需求选择合适的控制流语句,可以编写出高效、可维护的代码。
43 6
|
7月前
|
Java
switch的使用
这段 Java 代码首先提示用户输入一个代表月份的数字。通过 `Scanner` 类从键盘接收输入后,使用 `switch` 语句根据输入的数字来判断所属季节并输出相应的信息。例如,1、2 或 12 月为冬季。若输入不在 1 至 12 的范围内,则输出错误信息。此外,还展示了仅针对单个特定月份(如 1 月)进行匹配的简化示例。 ```markdown - 提示用户输入月份。 - 使用 `Scanner` 获取输入。 - 通过 `switch` 语句根据输入判断季节。 - 输出对应季节或错误信息。 - 展示了处理单个和多个月份的 `case` 示例。 ```
62 4
|
Java 编译器 C语言
【C/C++】 switch-case 详解/全面总结
关于 C语言/C++ 中,switch-case 的尽量详细和全面的解释与总结
1360 0
enum和switch case结合使用
在将enum和switch case结合使用的过程中,遇到了这个错误:“An enum switch case label must be the unqualified name of an enumeration constant”。
|
人工智能
jump game
最后一步:如果青蛙能跳到最后一块石头n-1,我们考虑他跳的最后一步,这一步是从石头i跳过来,i&lt;n-1 这需要两个条件同时满足: 1.青蛙可以调到石头i; 2.最后一步不超过跳跃的最大距离:n-1-i &lt;= ai
126 0
jump game
|
Dart
Dart之break、continue/ switch...case
Dart之break、continue/ switch...case
121 0
Dart之break、continue/ switch...case
switch case 执行
switch case 执行
149 0
|
机器学习/深度学习 关系型数据库 ice
Mishka and Game
Mishka and Game
138 0
Mishka and Game
switch—case需要注意的点
switch—case需要注意的点
272 0
switch—case需要注意的点