HDOJ 1081(ZOJ 1074) To The Max(动态规划)

简介: HDOJ 1081(ZOJ 1074) To The Max(动态规划)

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.


As an example, the maximal sub-rectangle of the array:


0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2


is in the lower left corner:


9 2

-4 1

-1 8


and has a sum of 15.


Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].


Output

Output the sum of the maximal sub-rectangle.


Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2


Sample Output

15


image.png

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[2000];
int dp[150][150];
int main(){
   int n;
   while(scanf("%d",&n)==1){
        int t;
      memset(dp,0,sizeof(dp));
      for(int i=1;i<=n;i++){
         for(int j=1;j<=n;j++){
            scanf("%d",&t);
            dp[i][j]=t+dp[i-1][j];
           /// printf("i=%d",i);
         }
      }
//        for(int i=0;i<=n;i++){
//         for(int j=0;j<=n;j++){
//                printf("%4d",dp[i][j]);
//         }
//         printf("\n");
//        }
      int maxx=-1000;
      for(int i=1;i<=n;i++){
          for(int j=i;j<=n;j++){
                int sum=0;
              for(int k=1;k<=n;k++){
                    t=dp[j][k]-dp[i-1][k];
                    sum+=t;
                    if(sum<0)  sum=0;
                    if(sum>maxx) maxx=sum;
              }
          }
      }
      printf("%d\n",maxx);
   }
   return 0;
}
目录
相关文章
|
7月前
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
25 0
|
7月前
hdoj 3555 BOMB(数位dp)
hdoj 3555 BOMB(数位dp)
19 0
HDOJ(HDU) 2107 Founding of HDU(找最大值)
HDOJ(HDU) 2107 Founding of HDU(找最大值)
71 0
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
67 0
|
Go
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
87 0
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
HDOJ(HDU) 2304 Electrical Outlets(求和、、)
87 0
HDOJ(HDU) 2161 Primes(素数打表)
HDOJ(HDU) 2161 Primes(素数打表)
85 0
HDOJ 1391 Number Steps(打表DP)
HDOJ 1391 Number Steps(打表DP)
98 0
HDOJ 1391 Number Steps(打表DP)
|
机器学习/深度学习 人工智能 BI
HDOJ/HDU 2550 百步穿杨(注意排序)
HDOJ/HDU 2550 百步穿杨(注意排序)
87 0
HDOJ/HDU 2551 竹青遍野(打表~)
HDOJ/HDU 2551 竹青遍野(打表~)
87 0