HDOJ 2057 A + B Again

简介: HDOJ 2057 A + B Again

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !


Input

The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.


Output

For each test case,print the sum of A and B in hexadecimal in one line.


Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA


Sample Output

0

2C

11

-2C

-90

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            long str1 = sc.nextLong(16);
            long str2 = sc.nextLong(16);
            long a = str1+str2;
            if(a<0){
                //System.out.println(a);
                a=-a;
                //System.out.println(a);
                System.out.println("-"+Long.toHexString(a).toUpperCase());
            }else{
                System.out.println(Long.toHexString(a).toUpperCase());
            }
        }
    }
}
目录
相关文章
HDOJ 2075 A|B?
HDOJ 2075 A|B?
83 0
HDOJ 1412 {A} + {B}
HDOJ 1412 {A} + {B}
127 0
HDOJ 2019 数列有序!
HDOJ 2019 数列有序!
136 0
HDOJ 1214 圆桌会议
Problem Description HDU ACM集训队的队员在暑假集训时经常要讨论自己在做题中遇到的问题.每当面临自己解决不了的问题时,他们就会围坐在一张圆形的桌子旁进行交流,经过大家的讨论后一般没有解决不了的问题,这也只有HDU ACM集训队特有的圆桌会议,有一天你也...
857 0
HDOJ 2057 A + B Again
Problem Description There must be many A + B problems in our HDOJ , now a new one is coming.
904 0
|
人工智能 BI
HDOJ 2040 亲和数
Problem Description 古希腊数学家毕达哥拉斯在自然数研究中发现,220的所有真约数(即不是自身的约数)之和为: 1+2+4+5+10+11+20+22+44+55+110=284。
871 0
|
编译器
HDOJ 2030
统计给定文本文件中汉字的个数 汉字机内码在计算机的表达方式的描述是,使用二个字节,每个字节最高位一位为1。 计算机中, 补码第一位是符号位, 1 表示为 负数, 所以 汉字机内码的每个字节表示的十进制数都是负数 统计输入字符串含有几个汉字,只只需求出字符串中小于0的字符有几个,将它除...
632 0