HDOJ 1715 大菲波数

简介: HDOJ 1715 大菲波数

Problem Description

Fibonacci数列,定义如下:

f(1)=f(2)=1

f(n)=f(n-1)+f(n-2) n>=3。

计算第n项Fibonacci数值。


Input

输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。


Output

输出为N行,每行为对应的f(Pi)。


Sample Input

5

1

2

3

4

5


Sample Output

1

1

2

3

5


属于水题吧,用java大数做的。

import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        BigDecimal[] f = new BigDecimal[1010];
        f[1]=new BigDecimal(1);
        f[2]=new BigDecimal(1);
        for(int i=3;i<=1000;i++){
            f[i] = f[i-1].add(f[i-2]);
        }
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int n = sc.nextInt();
            System.out.println(f[n]);
        }
    }
}
目录
相关文章
|
机器学习/深度学习
HDOJ 2074 叠筐
HDOJ 2074 叠筐
123 0
HDOJ 1323 Perfection(简单题)
Problem Description From the article Number Theory in the 1994 Microsoft Encarta: “If a, b, c are integers such that a = bc, a is called a...
850 0
HDOJ 2802 F(N)
Problem Description Giving the N, can you tell me the answer of F(N)? Input Each test case contains a single integer N(1
720 0
|
人工智能 算法
HDOJ 3466 Proud Merchants
Problem Description Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world.
965 0
|
Java BI 数据安全/隐私保护
HDOJ 2100 Lovekey
Problem Description XYZ-26进制数是一个每位都是大写字母的数字。 A、B、C、…、X、Y、Z 分别依次代表一个0 ~ 25 的数字,一个 n 位的26进制数转化成是10进制的规则如下 A0A1A2A3…An-1 的每一位代表的数字为a0a1a2a3…...
747 0
HDOJ 2041 超级楼梯
Problem Description 有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法? Input 输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1
564 0
|
测试技术
HDOJ 2033 人见人爱A+B
Problem Description HDOJ上面已经有10来道A+B的题目了,相信这些题目曾经是大家的最爱,希望今天的这个A+B能给大家带来好运,也希望这个题目能唤起大家对ACM曾经的热爱。
961 0
|
存储 Java
HDOJ 2602
Bone Collector Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 14134    Accepted Submission(s...
935 0