HDU Humble Numbers

简介:             Humble Numbers    Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Problem Description A number whose only prime factors are 2,3,5 or 7 is called a h

            Humble Numbers


   Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

全部由2、3、5、7的因子组成的数,最简单的方法就是把他们全部模拟求出来,怎么感觉这个不像DP题啊,反正我不知道怎么用DP做 orz,最后输出有点坑爹,比如1011,应该输出1011th而不是1011st。

#include <iostream>
using namespace std ;
#define MaxValue 5890
int num[MaxValue] ;
int find_min(int a , int b , int c , int d)
{
	int temp = a < b ? a : b ;
	int index = c < d ? c : d ;
	return (temp < index ? temp : index) ;
}
void solve()
{
	int i = 0 ;
	int h1 , h2 , h3 , h4 ;
	int i1 , i2 , i3 , i4 ;
	i1 = i2 = i3 = i4 = 0 ;
	num[0] = 1 ;
	for (i = 1 ; i < 5890 ; ++ i)
     {
		h1 = num[i1] * 2 ;
		h2 = num[i2] * 3 ;
		h3 = num[i3] * 5 ;
		h4 = num[i4] * 7 ;

		int min = find_min(h1 , h2 , h3 , h4) ;
		num[i] = min ;
		if (min == h1) {
			++ i1 ;
		}
		if (min == h2) {
 			++ i2 ;
		}
		if (min == h3) {
			++ i3 ;
		}
		if (min == h4) {
			++ i4 ;
		}
	}
}
int main() {
	int i = 0 ;
	int n = 0 , t = 0 ;

	solve() ;
	while (cin >> n && n) {
		if (n %10== 1 && n%100 != 11) {
			cout << "The " << n << "st humble number is " << num[n-1] << "." << endl ;
		}
		else if (n %10== 2 && n%100 != 12) {
			cout << "The " << n << "nd humble number is " << num[n-1] << "." << endl ;
		}
		else if (n %10== 3 && n%100 != 13) {
			cout << "The " << n << "rd humble number is " << num[n-1] << "." << endl ;
		}
		else {
			cout << "The " << n << "th humble number is " << num[n-1] << "." << endl ;
		}
	}
	
	return 0 ;
}


目录
相关文章
|
8月前
|
Java
HDU-4552-怪盗基德的挑战书
HDU-4552-怪盗基德的挑战书
54 0
|
Java
hdu 2503 a/b + c/d
hdu 2503 a/b + c/d
50 0
畅通工程 HDU - 1232
畅通工程 HDU - 1232
85 0
|
人工智能 Java
hdu 1712 ACboy needs your help
ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。
146 0
HDU2203亲和串
博客水平见水平......目前阶段就是这么菜,我会好好努力的!毕业直接拿到阿里offer!
1232 0
|
机器学习/深度学习 Java 算法

热门文章

最新文章