1088. Rational Arithmetic (20)

简介: For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.
For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

long gcd(long a, long b){
    while(a){
        long t = a;
        a = b % a;
        b = t;
    }
    return b;
}

string func(long a, long b){
    if(a == 0) return "0";
    long t = gcd(a, b);
    a = a / t;
    b = b / t;
    string s;
    stringstream ss;
    int flag = 0;
    if(a < 0 && b < 0) {a = -a; b = -b;}
    if(a < 0 && b > 0) {flag = 1; a = -a;}
    if(a > 0 && b < 0) {flag = 1; b = -b;}
    if(flag) ss << "(-";
    
    if (a / b && a % b) {
        ss << a / b << ' ' << a % b << '/' << b;
    }else if(a / b){
        ss << a / b;
    }else{
        ss << a << '/' << b;
    }
    if(flag) ss << ")";
    getline(ss, s);
    
    return s;
}

int main(){
    long a1, b1, a2, b2;
    scanf("%ld/%ld %ld/%ld", &a1, &b1, &a2, &b2);

    long t1 = a1 * b2 + a2 * b1;
    long t2 = b1 * b2;
    string s1 = func(a1, b1);
    string s2 = func(a2, b2);
    cout << s1 << " + " << s2 << " = " << func(t1, t2) << endl;
    t1 = a1 * b2 - a2 * b1;
    cout << s1 << " - " << s2 << " = " << func(t1, t2) << endl;
    t1 = a1 * a2;
    t2 = b1 * b2;
    cout << s1 << " * " << s2 << " = " << func(t1, t2) << endl;
    cout << s1 << " / " << s2 << " = ";
    if(a2 == 0) cout << "Inf" << endl;
    else{
        t1 = a1 * b2;
        t2 = b1 * a2;
        cout << func(t1, t2) << endl;
    }
    
    return 0;
}

目录
相关文章
codeforces 285C - Building Permutation
题目大意是有一个含n个数的数组,你可以通过+1或者-1的操作使得其中的数是1--n中的数,且没有重复的数。 既然是这样的题意,那么我就应该把原数组中的数尽量往他最接近1--n中的位置放,然后求差绝对值之和,但有多个数,怎么使他们和最小,这样就要对其进行排序了,直接按大小给它们安排好位置,然后计算。
45 0
UVa11296 - Counting Solutions to an Integral Equation(枚举技巧)
UVa11296 - Counting Solutions to an Integral Equation(枚举技巧)
59 0
|
C++
【PAT甲级 - C++题解】1088 Rational Arithmetic
【PAT甲级 - C++题解】1088 Rational Arithmetic
65 0
|
索引
LeetCode 413. Arithmetic Slices
如果一个数列至少有三个元素,并且任意两个相邻元素之差相同,则称该数列为等差数列。
110 0
LeetCode 413. Arithmetic Slices
|
算法
1081. Rational Sum (20)
1081. Rational Sum (20)
145 0
1081. Rational Sum (20)
|
Windows
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
99 0
German Collegiate Programming Contest 2019 H . Historical Maths (二分 大数)
|
人工智能 BI
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
92 0
|
机器学习/深度学习 人工智能 Java
AtCoder Beginner Contest 215 D - Coprime 2 (质因子分解 gcd)
AtCoder Beginner Contest 215 D - Coprime 2 (质因子分解 gcd)
124 0
The 15th Chinese Northeast Collegiate Programming Contest C. Vertex Deletion(树形dp)
The 15th Chinese Northeast Collegiate Programming Contest C. Vertex Deletion(树形dp)
124 0
AtCoder Beginner Contest 214 F - Substrings(subsequence DP)
AtCoder Beginner Contest 214 F - Substrings(subsequence DP)
106 0

热门文章

最新文章