linux下安装apache(httpd-2.4.3版本)各种坑

简介:

博主的linux是ubuntu 14.04.3。

在安装apache最新版httpd-2.4.3的时候遇到各种坑。

先提供安装apache httpd-2.4.3所需要的包,博主已经整理好,下载地址:http://download.csdn.net/download/u013142781/9445609

里面包含了:

apache 安装包:httpd-2.4.3.tar.gz 
依赖的包:apr-1.4.6.tar.gz、apr-util-1.4.1.tar.gz、pcre-8.20.tar.bz2

一开始没有添加依赖包的时候安装httpd-2.4.3报“apr not found”错误!

然后添加了apr-1.4.6依赖,再次安装,又报“apr-util not found”错误!

然后又添加了apr-util-1.4.1依赖,再次安装,又报“pcre-config for libpcre not found”错误!!!

然后又添加了pcre-8.20依赖最后才安装成功!!!

接下来介绍详细的安装过程:

(1)先在/usr/local目录下创建这四个目录:

apache2 
apr 
apr-util 
pcre

如果对linux命令不熟悉的猿友可以看博主的另外一篇文章:项目部署、配置、查错常用到的Linux命令

(2)接下来:

将httpd-2.4.3.tar.gz解压到/usr/local/apache2 
apr-1.4.6.tar.gz解压到/usr/local/apr 
apr-util-1.4.1.tar.gz解压到/usr/local/apr-util 
pcre-8.20.tar.bz2解压到/usr/local/pcre

这时候如果你到/usr/local/apache2/httpd-2.4.3目录下执行如下命令:

./configure --prefix=/usr/local/apache2

   
   

    将会报“apr not found”错误。因此我们为保证不报错。先安装apr、apr-util和pcre这三个依赖。

    下面我们依次安装apr、apr-util和pcre,必须是依次安装。

    (3)安装apr:

    到/usr/local/apr/apr-1.4.6目录下依次执行如下命令:

    ./configure --prefix=/usr/local/apr
    make
    make install
    
     
     

      (4)接下来安装apr-util:

      到/usr/local/apr-util/apr-util-1.4.1目录下依次执行如下命令:

      ./configure --prefix=/usr/local/apr-util -with-apr=/usr/local/apr/bin/apr-1-config
      make
      make install
      
       
       

        (5)接下来安装pcre:

        到/usr/local/pcre/pcre-8.20目录下依次执行如下命令:

        ./configure --prefix=/usr/local/pcre
        make
        make install
        
         
         

          (6)最后安装apache:

          到/usr/local/apache2/httpd-2.4.3目录下依次执行如下命令:

          ./configure --prefix=/usr/local/apache2 --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util/ --with-pcre=/usr/local/pcre
          make
          make install
          
           
           


            启动apache:

            接下来进入/usr/local/apache2/bin目录下,执行如下命令启动apache 
            apachectl -k start 
            启动失败,发现报错了。

            解决方案,进入到/usr/local/apache2/conf下,vi httpd.conf编辑该文件,找到”#ServerName www.example.com:80“,在其下面一行添加”ServerName localhost:80“,然后保存退出。然后再次启动apache。

            如果对linux编辑命令不熟悉的可以阅读博主的另外一篇博客:Linux文件编辑命令详细整理

            •启动Apache:/usr/local/apache2/bin/apachectl -k start
            •停止Apache:/usr/local/apache2/bin/apachectl -k stop
            •重启Apache:/usr/local/apache2/bin/apachectl -k restart
            
             
             

              启动apache成功后,打开linux的浏览器访问:http://localhost:80

              博主的是阿里云服务器,所以访问地址为:http://120.25.235.171:80

              访问结果:

              这里写图片描述


























              相关文章
              |
              Ubuntu Linux
              Ubuntu 23.04 用上 Linux 6.2 内核,预计下放到 22.04 LTS 版本
              Linux 6.2 带来了多项内容更新,修复了 AMD 锐龙处理器设备在启用 fTPM 后的运行卡顿问题,还增强了文件系统。
              |
              Ubuntu Linux
              计算机基础知识:linux系统怎么安装?
              在虚拟机软件中创建一个新的虚拟机,并选择相应操作系统类型和硬盘空间大小等参数。将下载的 ISO 镜像文件加载到虚拟机中。启动虚拟机,进入安装界面,并按照步骤进行安装。安装完成后,可以在虚拟机中使用 Linux 系统。
              |
              12月前
              |
              安全 Linux iOS开发
              Nessus Professional 10.10 Auto Installer for RHEL 10, AlmaLinux 10, Rocky Linux 10 - Nessus 自动化安装程序
              Nessus Professional 10.10 Auto Installer for RHEL 10, AlmaLinux 10, Rocky Linux 10 - Nessus 自动化安装程序
              789 6
              Nessus Professional 10.10 Auto Installer for RHEL 10, AlmaLinux 10, Rocky Linux 10 - Nessus 自动化安装程序
              |
              12月前
              |
              消息中间件 Kafka Linux
              Linux下安装Kafka 3.9.1
              本文介绍Kafka 3.9.1版本的安装与配置,包括通过ZooKeeper或KRaft模式启动Kafka。涵盖环境变量设置、日志路径修改、集群UUID生成、存储格式化及服务启停操作,适用于Linux环境下的部署实践。
              1377 0
              |
              网络协议 关系型数据库 Linux
              【App Service Linux】在Linux App Service中安装 tcpdump 并抓取网络包
              在App Service for Linux环境中,无法像Windows一样直接使用网络排查工具抓包。本文介绍了如何通过TCPDUMP在Linux环境下抓取网络包,包括SSH进入容器、安装tcpdump、执行抓包命令及下载分析文件的完整操作步骤。
              572 5
              |
              弹性计算 安全 Linux
              阿里云服务器ECS安装宝塔Linux面板、安装网站(新手图文教程)
              本教程详解如何在阿里云服务器上安装宝塔Linux面板,涵盖ECS服务器手动安装步骤,包括系统准备、远程连接、安装命令执行、端口开放及LNMP环境部署,手把手引导用户快速搭建网站环境。
              |
              SQL 存储 JSON
              Apache Doris 2.1.10 版本正式发布
              亲爱的社区小伙伴们,Apache Doris 2.1.10 版本已正式发布。2.1.10 版本对湖仓一体、半结构化数据类型、查询优化器、执行引擎、存储管理进行了若干改进优化。欢迎大家下载使用。
              609 5
              |
              Ubuntu 安全 小程序
              linux|ubuntu.v18.10版本即将发布,linux桌面让您动心
              如果你使用闭源系统,那永远也就别想了!有了这样的需求,也许最终将linux带到人类大众通用市场的是我们中国!
              517 0