华为与思科BGP的基本配置命令-阿里云开发者社区

开发者社区> 技术小胖子> 正文

华为与思科BGP的基本配置命令

简介:
+关注继续查看
华为与思科BGP的基本配置命令
思科的配置命令:
下面的拓扑图用的是类的IP地址,为了便于理解,我用路由器之间的名字作为IP地址的

下面的是R1R8的关于BGP的配置命令(R1-R6AS65001R7-R8AS65002,两个AS间运行静态路由)
注:看上图R1-R6之间我不建立全互联,只与它们直连网段的路由器建立邻居关系,然后在R2R5上做路由反射器
R1的配置命令
R1(config)#router bgp 65001              //启动BGP的进程
R1(config-router)#bgp router-id 1.1.1.1     
R1(config-router)#no synchronization        //关闭同步
R1(config-router)#bgp log-neighbor-changes  //用于网管监控邻居状态的改变
R1(config-router)#no auto-summary        //关闭自动汇总
R1(config-router)#network 202.106.1.0 mask 255.255.255.0 //M1上的主机的IP地址通告出去(M1R1R4做的VRRP过程略)
R1(config-router)#neighbor 2.2.2.2 remote-as 65001 //指定邻居路由器所在的AS
R1(config-router)#neighbor 2.2.2.2 update-source loo0 //指定更新源
R1(config-router)#neighbor 5.5.5.5 remote-as 65001
R1(config-router)#neighbor 5.5.5.5 update-source loo0
R2的配置命令
R2(config)#router bgp 65001
R2(config-router)#bgp router-id 2.2.2.2
R2(config-router)#no synchronization
R2(config-router)#no auto-summary
R2(config-router)#bgp log-neighbor-changes
R2(config-router) bgp cluster-id 10 //在一个网络中有两台路由器做反射器[R2R3R5R6做路由反映器]时要指定cluster-id的,而且id号是要一样的
R2(config-router) neighbor 3.3.3.3 route-reflector-client   //指定客户端为R3R2R3路由的反射器)
R2(config-router)#neighbor 1.1.1.1 remote-as 65001
R2(config-router)#neighbor 1.1.1.1 update-source loo0
R2(config-router)#neighbor 4.4.4.4 remote-as 65001  
R2(config-router)#neighbor 4.4.4.4 update-source loo0
R2(config-router)#neighbor 3.3.3.3 remote-as 65001  
R2(config-router)#neighbor 3.3.3.3 update-source loo0 
R2(config-router)#neighbor 5.5.5.5 remote-as 65001  
R2(config-router)#neighbor 5.5.5.5 update-source loo0
R3的配置命令
R3(config)#router bgp 65001
R3(config-router)#no synchronization
R3(config-router)#no auto-summary
R3(config-router)#bgp log-neighbor-changes
R3(config-router)#bgp router-id 3.3.3.3
R3(config-router)#neighbor 2.2.2.2 remote-as 65001
R3(config-router)#neighbor 2.2.2.2 update-source loo0
R3(config-router)#neighbor 2.2.2.2 next-hop-self  //配置下一跳自我,即对从EBGP邻居转入的路由,在通告给IBGP邻居的同时,强迫路由器通告自己是发送BGP更新的下一跳,而不是EBGP    
R3(config-router)#neighbor 6.6.6.6 remote-as 65001
R3(config-router)#neighbor 6.6.6.6 update-source loo0
R3(config-router)#neighbor 6.6.6.6 next-hop-self
R3(config-router)#neighbor 7.7.7.7 remote-as 65002
R3(config-router)#neighbor 7.7.7.7 update-source loo0
R3(config-router)#neighbor 7.7.7.7 ebgp-multihop 2   //将邻居7.7.7.7的路数该为2,因为用的是环回口来建的邻居关系
R3(config)#ip route 7.7.7.7 255.255.255.255 192.168.37.7
R4的配置命令
R4(config)#router bgp 65001
R4(config-router)#no synchronization
R4(config-router)#no auto-summary
R4(config-router)#bgp log-neighbor-changes
R4(config-router)#bgp router-id 4.4.4.4
R4(config-router)#network 202.106.1.0 mask 255.255.255.0 //M1上的主机的IP地址通告出去
R4(config-router)#neighbor 2.2.2.2 remote-as 65001
R4(config-router)#neighbor 2.2.2.2 update-source loo0
R4(config-router)#neighbor 5.5.5.5 remote-as 65001  
R4(config-router)#neighbor 5.5.5.5 update-source loo0
R5的配置命令
R5(config)#router bgp 65001
R5(config-router)#no synchronization
R5(config-router)#no auto-summary
R5(config-router)#bgp log-neighbor-changes
R5(config-router)#bgp router-id 5.5.5.5
R5(config-router)# bgp cluster-id 10 
R5(config-router)# neighbor 6.6.6.6 route-reflector-client //指定客户端为R6
R5(config-router)#neighbor 2.2.2.2 remote-as 65001
R5(config-router)#neighbor 2.2.2.2 update-source lo0
R5(config-router)#neighbor 4.4.4.4 remote-as 65001 
R5(config-router)#neighbor 4.4.4.4 update-source lo0
R5(config-router)#neighbor 6.6.6.6 remote-as 65001 
R5(config-router)#neighbor 6.6.6.6 update-source lo0
R6的配置命令
R6(config)#router bgp 65001
R6(config-router)#no synchronization
R6(config-router)#no auto-summary
R6(config-router)#bgp log-neighbor-changes
R6(config-router)#bgp router-id 6.6.6.6
R6(config-router)#neighbor 3.3.3.3 remote-as 65001
R6(config-router)#neighbor 3.3.3.3 update-source loo0
R6(config-router)#neighbor 3.3.3.3 next-hop-self
R6(config-router)#neighbor 5.5.5.5 remote-as 65001
R6(config-router)#neighbor 5.5.5.5 update-source lo0
R6(config-router)#neighbor 5.5.5.5 next-hop-self
R6(config-router)#neighbor 8.8.8.8 remote-as 65002
R6(config-router)#neighbor 8.8.8.8 update-source loo0
R6(config-router)#neighbor 8.8.8.8 ebgp-multihop 2
R6(config)#ip route 8.8.8.8 255.255.255.255 192.168.68.8
 
R7的配置命令
R7(config)#ip route 8.8.0.0 255.255.240.0 null 0
R7(config)#router bgp 65002
R7(config-router)#no synchronization
R7(config-router)#no auto-summary
R7(config-router)#bgp log-neighbor-changes
R7(config-router)#bgp router-id 8.8.8.8
R7(config-router)# neighbor 3.3.3.3 remote-as 65001
R7(config-router)# neighbor 3.3.3.3 ebgp-multihop 2
R7(config-router)# neighbor 3.3.3.3 update-source Loopback0
R7(config-router)#neighbor 8.8.8.8 remote-as 65002
R7(config-router)#neighbor 8.8.8.8 update-source Loopback0
R7(config-router)#neighbor 8.8.8.8 next-hop-self
R7(config-router)#aggregate-address 8.8.0.0 255.255.252.0 summary-only // aggregate-address 汇总后的地址和掩码 summary-only ;这样就只有汇总路由可以优,明细被抑制(S
R7(config-router)#network 8.8.0.0 mask 255.255.252.0 //R7下的环回口下的虚拟主机的IP通告出去(8.8.0.1-8.8.3.1
R7(config)#ip route 8.8.0.0 255.255.252.0 Null0 //直接network 一条汇总后路由,但由于本地路由表中没有此路由所以不会通告,通过手动添加一条指向null0的汇总路由实现
R7(config)#ip route 3.3.3.3 255.255.255.255 192.168.37.3
R8的配置命令
R8(config)#router bgp 65002
R8(config-router)#no synchronization
R8(config-router)#no auto-summary
R8(config-router)#bgp log-neighbor-changes
R8(config-router)#bgp router-id 8.8.8.8
R8(config-router)#neighbor 6.6.6.6 remote-as 65001
R8(config-router)#neighbor 6.6.6.6 update-source loo0
R8(config-router)#neighbor 6.6.6.6 ebgp-multihop 2
R8(config-router)#neighbor 7.7.7.7 remote-as 65002
R8(config-router)#neighbor 7.7.7.7 update-source loo0
R8(config)#ip route 6.6.6.6 255.255.255.255 192.168.68.6
R1R7上查看学到了它们各自的通告
 

M1pingR7上的虚拟主机是可以通的
 

查看命令:
1、          sh ip bgp   //查看bgp的表信息
2、          sh ip bgp summary  //查看邻居表信息
3、          sh ip bgp neighbors ipv4-address advertised-routes  //查看向邻居通告的路由
4、          sh ip route bgp //查看bgp的路由
 
华为的配置:
如下图所示,为了好理解用它们的之间相连的主机名字的来做的IP地址(C类的地址 /30的掩码)
蓝色区域的为Area1,绿色区域的为Area2,它们之间用的是ISIS的协议。R7R8之间也是做的ISIS的,但是不向R3R6那边通告的R3R7R6R8它们之间要运行EBGP的)
下面命令:0 0表示永不超时,不管什么时候都不会返回初始状态
用下面这个命令关闭上面在操作过程中弹出的弹出的信息,这样就不会打扰操作了
ISIS的配置:
R1上的配置文件R4的配置和R1的相似略)
#
sysname Huawei
#
isis 1
 is-level level-1   //类型为level-1
 network-entity 49.0001.0010.0100.1001.00
#
interface GigabitEthernet0/0/0  //进接口
 ip address 192.168.12.1 255.255.255.252
 isis enable 1  //开启ISIS的协议
#
interface GigabitEthernet0/0/3
 ip address 192.168.15.1 255.255.255.252
 isis enable 1
R2上的配置文件R5的配置和R2的相似略)
#
sysname Huawei
#
isis 1
 network-entity 49.0001.0020.0200.2002.00
is-level level-1-2 //类型为level-1-2
import-route isis level-2 into level-1 (这条命令一定要打的,不然后面做BGP时是学不到EBGP通告的路由) //level-2的路由引入到level-1中。该命令配置在与外部区域相连的Level-1-2路由器上。缺省情况下,Level-2的路由信息不发布到Level-1区域中
undo import-route isis level-1 into level-2 //不将Level-1的路由信息发布到Level-2中。该命令配置在与外部区域相连的Level-1-2路由器上。缺省情况下,Level-1的路由信息都将发布到Level-2区域中。
#
interface GigabitEthernet0/0/0
 ip address 192.168.12.2 255.255.255.252
 isis enable 1
#
interface GigabitEthernet0/0/1
 ip address 192.168.23.1 255.255.255.252
 isis enable 1
#
interface GigabitEthernet0/0/2
 ip address 192.168.25.1 255.255.255.252
 isis enable 1
#
interface GigabitEthernet0/0/3
 ip address 192.168.24.1 255.255.255.252
 isis enable 1
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
 isis enable 1
#
R3上的配置文件R6的配置和R3的相似略)
#
isis 2
 is-level level-2 //类型为level-2
 network-entity 49.0002.0030.0300.3003.00
#
interface GigabitEthernet0/0/0
 ip address 192.168.37.1 255.255.255.252
#
interface GigabitEthernet0/0/1
 ip address 192.168.23.2 255.255.255.252
 isis enable 2
#
interface GigabitEthernet0/0/2
 ip address 192.168.36.1 255.255.255.252
 isis enable 2
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255
 isis enable 2
R7上的配置文件R8的配置和R7的相似略)
#
sysname Huawei
#
isis 3
 is-level level-1
 network-entity 49.0003.0070.0700.7007.00
#
interface GigabitEthernet0/0/0
 ip address 192.168.37.2 255.255.255.252
#
interface GigabitEthernet0/0/1
 ip address 192.168.78.1 255.255.255.252
 isis enable 3
#
interface LoopBack0
 ip address 7.7.7.7 255.255.255.255
 isis enable 3
#
interface LoopBack1
 ip address 192.168.0.1 255.255.255.0
 isis enable 3
#
interface LoopBack2
 ip address 192.168.1.1 255.255.255.0
 isis enable 3
#
interface LoopBack3
 ip address 192.168.2.1 255.255.255.0
 isis enable 3
#
interface LoopBack4
 ip address 192.168.3.1 255.255.255.0
 isis enable 3
 
BGP的配置命令
注:看上图R1-R6之间我不建立全互联,只与它们直连网段的路由器建立邻居关系,然后在R2R5上做路由反射器
AR1的配置命令
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization //关闭同步
[Huawei-bgp]router-id 1.1.1.1 //配置BGPRouter ID
[Huawei-bgp]peer 2.2.2.2 as-number 65001 //指定对等体的IP地址及其所属的AS编号
[Huawei-bgp]peer 2.2.2.2 connect-interface loo0 //更新源
[Huawei-bgp]peer 5.5.5.5 as-number 65001
[Huawei-bgp]peer 5.5.5.5 connect-interface LoopBack0
AR2的配置命令
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization
[Huawei-bgp]router-id 2.2.2.2
[Huawei-bgp] peer 1.1.1.1 as-number 65001 //指定对等体的IP地址及其所属的AS编号
[Huawei-bgp]peer 1.1.1.1 connect-interface LoopBack0
[Huawei-bgp]peer 3.3.3.3 as-number 65001
[Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack0
[Huawei-bgp]peer 4.4.4.4 as-number 65001
[Huawei-bgp]peer 4.4.4.4 connect-interface LoopBack0
[Huawei-bgp]peer 5.5.5.5 as-number 65001
[Huawei-bgp]peer 5.5.5.5 connect-interface LoopBack0
[Huawei-bgp]reflector cluster-id 2  //配置路由反射器的集群ID
[Huawei-bgp]peer 3.3.3.3 reflect-client//指定客户端
AR3的配置命令
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization //关闭同步
[Huawei-bgp]router-id 3.3.3.3
[Huawei-bgp] peer 2.2.2.2 as-number 65001
[Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack0
[Huawei-bgp]peer 2.2.2.2 next-hop-local
[Huawei-bgp]peer 6.6.6.6 as-number 65001
[Huawei-bgp]peer 6.6.6.6 connect-interface LoopBack0
[Huawei-bgp]peer 6.6.6.6 next-hop-local    //指定下一跳是自己
[Huawei-bgp]peer 7.7.7.7 as-number 65002
[Huawei-bgp]peer 7.7.7.7 ebgp-max-hop 2 //两个AS之间用环回口建的邻居要将它们的邻居的路数改为2,默认的是1
[Huawei-bgp]peer 7.7.7.7 connect-interface LoopBack0
[Huawei]ip route-static 7.7.7.7 255.255.255.255 192.168.37.2 //两个AS之间要运行静态路由
AR4的配置命令
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization 
[Huawei-bgp]router-id 4.4.4.4
[Huawei-bgp]peer 2.2.2.2 as-number 65001
[Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack0
[Huawei-bgp]peer 5.5.5.5 as-number 65001
[Huawei-bgp]peer 5.5.5.5 connect-interface LoopBack0
AR5的配置命令
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization
[Huawei-bgp]router-id 5.5.5.5
[Huawei-bgp]peer 1.1.1.1 as-number 65001 
[Huawei-bgp]peer 1.1.1.1 connect-interface LoopBack0
[Huawei-bgp]peer 2.2.2.2 as-number 65001
[Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack0
[Huawei-bgp]peer 4.4.4.4 as-number 65001
[Huawei-bgp]peer 4.4.4.4 connect-interface LoopBack0
[Huawei-bgp]peer 6.6.6.6 as-number 65001
[Huawei-bgp]peer 6.6.6.6 connect-interface LoopBack0
[Huawei-bgp]reflector cluster-id 2 //配置路由反射器的集群ID
[Huawei-bgp]peer 6.6.6.6 reflect-client //指定客户
AR6的配置
[Huawei]bgp 65001
[Huawei-bgp]undo synchronization 
[Huawei]router-id 6.6.6.6
[Huawei-bgp]peer 3.3.3.3 as-number 65001
[Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack0
[Huawei-bgp]peer 3.3.3.3 next-hop-local
[Huawei-bgp]peer 5.5.5.5 as-number 65001
[Huawei-bgp]peer 5.5.5.5 connect-interface LoopBack0
[Huawei-bgp]peer 5.5.5.5 next-hop-local
[Huawei-bgp]peer 8.8.8.8 as-number 65002
[Huawei-bgp]peer 8.8.8.8 ebgp-max-hop 2 //两个AS之间用环回口建的邻居要将它们的邻居的路数改为2,默认的是1
[Huawei-bgp]peer 8.8.8.8 connect-interface LoopBack0
[Huawei]ip route-static 8.8.8.8 255.255.255.255 192.168.68.2 //两个AS之间要运行静态路由
AR7的配置命令
[Huawei]bgp 65002
[Huawei-bgp]undo synchronization  
[Huawei-bgp]router-id 7.7.7.7
[Huawei-bgp]peer 3.3.3.3 as-number 65001
[Huawei-bgp]peer 3.3.3.3 ebgp-max-hop 2 //两个AS之间用环回口建的邻居要将它们的邻居的路数改为2,默认的是1
[Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack0
[Huawei-bgp]peer 8.8.8.8 as-number 65002
[Huawei-bgp]peer 8.8.8.8 connect-interface LoopBack0
[Huawei-bgp]peer 8.8.8.8 next-hop-local
[Huawei-bgp]aggregate 192.168.0.0 255.255.252.0 detail-suppressed //配置手动路由聚合用aggregatedetail-suppressed是抑制明细路由的通告
[Huawei-bgp]network 192.168.0.0 255.255.252.0 //将这个聚合的路由通告出去
[Huawei]ip route-static 192.168.0.0 255.255.252.0 NULL0 //将聚合的路由通告出去,因为在手动汇总的这个192.168.0.0在路由表中是不存在的的,要把它加入到NULL 0里才能在bgp进程里用上面的network来通告这条路由
[Huawei]ip route-static 3.3.3.3 255.255.255.255 192.168.37.1 //两个AS之间要运行静态路由
AR8的配置命令
[Huawei]bgp 65002
[Huawei-bgp]undo synchronization
[Huawei-bgp]router-id 8.8.8.8
[Huawei-bgp]peer 6.6.6.6 as-number 65001
[Huawei-bgp]peer 6.6.6.6 ebgp-max-hop 2 //两个AS之间用环回口建的邻居要将它们的邻居的路数改为2,默认的是1
[Huawei-bgp]peer 6.6.6.6 connect-interface LoopBack0
[Huawei-bgp]peer 7.7.7.7 as-number 65002
[Huawei-bgp]peer 7.7.7.7 connect-interface LoopBack0
[Huawei]ip route-static 6.6.6.6 255.255.255.255 192.168.68.1 //两个AS之间要运行静态路由
这是在R7上通告的汇总路由

 

 

检查命令
1display bgp peer //查看bgp的对等信息 Established为成功建立
2diplay bgp routing-table //查看bgp的路由表信息
3diplay bgp peer ipv4-address verbose //查看bgp的某个邻居(对等体)的详细信息
4display bgp paths  //查看AS路径信息
5display bgp network  //查看bgp发布的路由信息(我这个拓扑里是在R7通告的,所以在R7上用这个命令)
6display bgp routing-table cidr //查看cidr路由信息(不加cidr也行的)
7display bgp routing-table peer ipv4-address advertised-routes  //查看bgp对等体发布(通告)的路由
8display bgp routing-table peer ipv4-address received-ro      utes //查看bgp对等体收到的路由信息
9display ip routing-table (verbose) //查看路由表信息
10dis current-configuration //查看当前的配置命令
11、当BGP路由策略(路由器不支持Router Refresh)或配置发生变化后,需要通过复位BGP连接使新的配置生效。如果需要复位BGP连接,可在用户视图下选择执行以下命令
 12在出现BGP运行故障时,请在用户视图下执行表中的debugging命令对BGP进行调试,查看调试信息,定位故障并分析故障原因。
调试完毕后,应及时执行undo debugging all命令关闭调试开关
 

 

 


      本文转自ling118 51CTO博客,原文链接:http://blog.51cto.com/meiling/1062267,如需转载请自行联系原作者






版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
阿里云服务器怎么设置密码?怎么停机?怎么重启服务器?
如果在创建实例时没有设置密码,或者密码丢失,您可以在控制台上重新设置实例的登录密码。本文仅描述如何在 ECS 管理控制台上修改实例登录密码。
9035 0
使用NAT网关轻松为单台云服务器设置多个公网IP
在应用中,有时会遇到用户询问如何使单台云服务器具备多个公网IP的问题。 具体如何操作呢,有了NAT网关这个也不是难题。
26691 0
阿里云服务器端口号设置
阿里云服务器初级使用者可能面临的问题之一. 使用tomcat或者其他服务器软件设置端口号后,比如 一些不是默认的, mysql的 3306, mssql的1433,有时候打不开网页, 原因是没有在ecs安全组去设置这个端口号. 解决: 点击ecs下网络和安全下的安全组 在弹出的安全组中,如果没有就新建安全组,然后点击配置规则 最后如上图点击添加...或快速创建.   have fun!  将编程看作是一门艺术,而不单单是个技术。
10713 0
使用SSH远程登录阿里云ECS服务器
远程连接服务器以及配置环境
2443 0
阿里云服务器如何登录?阿里云服务器的三种登录方法
购买阿里云ECS云服务器后如何登录?场景不同,阿里云优惠总结大概有三种登录方式: 登录到ECS云服务器控制台 在ECS云服务器控制台用户可以更改密码、更换系.
12721 0
腾讯云服务器 设置ngxin + fastdfs +tomcat 开机自启动
在tomcat中新建一个可以启动的 .sh 脚本文件 /usr/local/tomcat7/bin/ export JAVA_HOME=/usr/local/java/jdk7 export PATH=$JAVA_HOME/bin/:$PATH export CLASSPATH=.
4590 0
阿里云服务器如何登录?阿里云服务器的三种登录方法
购买阿里云ECS云服务器后如何登录?场景不同,云吞铺子总结大概有三种登录方式: 登录到ECS云服务器控制台 在ECS云服务器控制台用户可以更改密码、更换系统盘、创建快照、配置安全组等操作如何登录ECS云服务器控制台? 1、先登录到阿里云ECS服务器控制台 2、点击顶部的“控制台” 3、通过左侧栏,切换到“云服务器ECS”即可,如下图所示 通过ECS控制台的远程连接来登录到云服务器 阿里云ECS云服务器自带远程连接功能,使用该功能可以登录到云服务器,简单且方便,如下图:点击“远程连接”,第一次连接会自动生成6位数字密码,输入密码即可登录到云服务器上。
21807 0
21119
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载