cisco路由器基本实验之四 动态路由之IGRP协议的配置(Boson NetSim)-阿里云开发者社区

开发者社区> 云计算> 正文
登录阅读全文

cisco路由器基本实验之四 动态路由之IGRP协议的配置(Boson NetSim)

简介:
   又快到了开学的时间了,所以最近要整理一些开学用的东西,可能要忙一点了,但是cisco系列的基本实验还是得完成,把它们写在博客上也可以作为自己学习路上的的见证,哈哈,闲话不说,还是看实验。今天是配置IGRP协议(Interior Gateway Routing Protocol),据说这个已经不用了(听朋友说的),CCNA都不考这个了,但是我认为这个还是值得实验一下的,有些东西并不是说不考就不用掌握的。
       
跟以前一样,下面将会把路由器和主机的配置情况贴出来,关键语句有注释,需要改进的地方还请众网友多多指点!
router1的配置:
 
Press Enter to Start

Router>
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface e0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Router(config-if)#interface s0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 6400
Router(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
Router(config-if)#exit
%LINK-3-UPDOWN: Interface Serial0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
Router(config)#router igrp 100                  //在igrp协议名后面需要写上as号,同一自治域内的路由器才能交换路由信息,此处约定为100
Router(config-router)#network 192.168.1.0        //同rip,也要写上直连网络,非以太网还要写上neighbor(邻接路由器的相邻端口IP地址)
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
Router(config)#hostname router1
router1(config)#exit
router1#copy running-config startup-config 
Destination filename [startup-config]?
Building configuration...
[OK]
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
router1#
 
router2 的配置:
 
Press Enter to Start

Router>
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface s0
Router(config-if)#exit
Router(config)#hostname router2
router2(config)#interface s0
router2(config-if)#ip address 192.168.2.2 255.255.255.0
router2(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
router2(config-if)#interface s0
router2(config-if)#interface e0
router2(config-if)#ip address 192.168.3.1 255.255.255.0
router2(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
router2(config-if)#exit
router2(config)#router igrp 100
router2(config-router)#network 192.168.3.0
router2(config-router)#network 192.168.2.0
router2(config-router)#exit
router2(config)#exit
router2#copy running-config startup-config 
Destination filename [startup-config]?
Building configuration...
[OK]
router2#ping 192.168.1.2             //开始测试,结果正确

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
router2#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
router2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
router2#
 
pc1的配置:
 
Boson BOSS 5.0
Copyright 1998-2003 Boson Software, Inc.
Use the command help to get started
Press Enter to begin
C:>ipconfig /ip 192.168.1.1 255.255.255.0
C:>ipconfig /dg 192.168.1.2
C:>ping 192.168.3.2
Pinging 192.168.3.2 with 32 bytes of data:         //不说了,完全正确
Reply from 192.168.3.2: bytes=32 time=60ms TTL=241
Reply from 192.168.3.2: bytes=32 time=60ms TTL=241
Reply from 192.168.3.2: bytes=32 time=60ms TTL=241
Reply from 192.168.3.2: bytes=32 time=60ms TTL=241
Reply from 192.168.3.2: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.3.2:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
C:>ping 192.168.3.1
Pinging 192.168.3.1 with 32 bytes of data:
Reply from 192.168.3.1: bytes=32 time=60ms TTL=241
Reply from 192.168.3.1: bytes=32 time=60ms TTL=241
Reply from 192.168.3.1: bytes=32 time=60ms TTL=241
Reply from 192.168.3.1: bytes=32 time=60ms TTL=241
Reply from 192.168.3.1: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.3.1:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
C:>ping 192.168.2.2
Pinging 192.168.2.2 with 32 bytes of data:
Reply from 192.168.2.2: bytes=32 time=60ms TTL=241
Reply from 192.168.2.2: bytes=32 time=60ms TTL=241
Reply from 192.168.2.2: bytes=32 time=60ms TTL=241
Reply from 192.168.2.2: bytes=32 time=60ms TTL=241
Reply from 192.168.2.2: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.2.2:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
C:>ping 192.168.2.1
Pinging 192.168.2.1 with 32 bytes of data:
Reply from 192.168.2.1: bytes=32 time=60ms TTL=241
Reply from 192.168.2.1: bytes=32 time=60ms TTL=241
Reply from 192.168.2.1: bytes=32 time=60ms TTL=241
Reply from 192.168.2.1: bytes=32 time=60ms TTL=241
Reply from 192.168.2.1: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.2.1:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
C:>ping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data:
Reply from 192.168.1.2: bytes=32 time=60ms TTL=241
Reply from 192.168.1.2: bytes=32 time=60ms TTL=241
Reply from 192.168.1.2: bytes=32 time=60ms TTL=241
Reply from 192.168.1.2: bytes=32 time=60ms TTL=241
Reply from 192.168.1.2: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.1.2:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
C:>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time=60ms TTL=241
Reply from 192.168.1.1: bytes=32 time=60ms TTL=241
Reply from 192.168.1.1: bytes=32 time=60ms TTL=241
Reply from 192.168.1.1: bytes=32 time=60ms TTL=241
Reply from 192.168.1.1: bytes=32 time=60ms TTL=241
Ping statistics for 192.168.1.1:     Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
pc2的配置:
 
Boson BOSS 5.0
Copyright 1998-2003 Boson Software, Inc.
Use the command help to get started
Press Enter to begin
C
Cipconfig ip 192.168.3.2 255.255.255.0
Cipconfig dg 192.168.3.1
Cping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data
Reply from 192.168.1.1 bytes=32 time=60ms TTL=241
Reply from 192.168.1.1 bytes=32 time=60ms TTL=241
Reply from 192.168.1.1 bytes=32 time=60ms TTL=241
Reply from 192.168.1.1 bytes=32 time=60ms TTL=241
Reply from 192.168.1.1 bytes=32 time=60ms TTL=241
Ping statistics for 192.168.1.1     Packets Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
Cping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data
Reply from 192.168.1.2 bytes=32 time=60ms TTL=241
Reply from 192.168.1.2 bytes=32 time=60ms TTL=241
Reply from 192.168.1.2 bytes=32 time=60ms TTL=241
Reply from 192.168.1.2 bytes=32 time=60ms TTL=241
Reply from 192.168.1.2 bytes=32 time=60ms TTL=241
Ping statistics for 192.168.1.2     Packets Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
Cping 192.168.2.1
Pinging 192.168.2.1 with 32 bytes of data
Reply from 192.168.2.1 bytes=32 time=60ms TTL=241
Reply from 192.168.2.1 bytes=32 time=60ms TTL=241
Reply from 192.168.2.1 bytes=32 time=60ms TTL=241
Reply from 192.168.2.1 bytes=32 time=60ms TTL=241
Reply from 192.168.2.1 bytes=32 time=60ms TTL=241
Ping statistics for 192.168.2.1     Packets Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
Cping 192.168.2.2
Pinging 192.168.2.2 with 32 bytes of data
Reply from 192.168.2.2 bytes=32 time=60ms TTL=241
Reply from 192.168.2.2 bytes=32 time=60ms TTL=241
Reply from 192.168.2.2 bytes=32 time=60ms TTL=241
Reply from 192.168.2.2 bytes=32 time=60ms TTL=241
Reply from 192.168.2.2 bytes=32 time=60ms TTL=241
Ping statistics for 192.168.2.2     Packets Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
     Minimum = 50ms, Maximum =  60ms, Average =  55ms
Cping 192.168.3.1
Pinging 192.168.3.1 with 32 bytes of data
Reply from 192.168.3.1 bytes=32 time=60ms TTL=241
Reply from 192.168.3.1 bytes=32 time=60ms TTL=241
Reply from 192.168.3.1 bytes=32 time=60ms TTL=241
Reply from 192.168.3.1 bytes=32 time=60ms TTL=241
Reply from 192.168.3.1 bytes=32 time=60ms TTL=241
Ping statistics for 192.168.3.1     Packets Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
     Minimum = 50ms, Maximum =  60ms, Average =  55ms

本文转自 victoryan 51CTO博客,原文链接:http://blog.51cto.com/victoryan/39047

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

其他文章