HDU 4081-Parsing URL(水)

简介:

Parsing URL

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 1575    Accepted Submission(s): 796


Problem Description
In computing, a Uniform Resource Locator or Universal Resource Locator (URL) is a character string that specifies where a known resource is available on the Internet and the mechanism for retrieving it.
The syntax of a typical URL is:
scheme://domain:port/path?query_string#fragment_id
In this problem, the scheme, domain is required by all URL and other components are optional. That is, for example, the following are all correct urls:
http://dict.bing.com.cn/#%E5%B0%8F%E6%95%B0%E7%82%B9
http://www.mariowiki.com/Mushroom
https://mail.google.com/mail/?shva=1#inbox
http://en.wikipedia.org/wiki/Bowser_(character)
ftp://fs.fudan.edu.cn/
telnet://bbs.fudan.edu.cn/
http://mail.bashu.cn:8080/BsOnline/
Your task is to find the domain for all given URLs.
 

Input
There are multiple test cases in this problem. The first line of input contains a single integer denoting the number of test cases.
For each of test case, there is only one line contains a valid URL.
 

Output
For each test case, you should output the domain of the given URL.
 

Sample Input
 
 
3 http://dict.bing.com.cn/#%E5%B0%8F%E6%95%B0%E7%82%B9 http://www.mariowiki.com/Mushroom https://mail.google.com/mail/?shva=1#inbox
 

Sample Output
 
 
Case #1: dict.bing.com.cn Case #2: www.mariowiki.com Case #3: mail.google.com
训练一下高速找到水题并切掉的能力。。毕竟现场赛仅仅能做水题了。

。7分钟1A

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <cmath>
#include <map>
using namespace std;
#define LL long long
char s[10010],ans[10010];
int main()
{
	//ios::sync_with_stdio(false);
	int t,p,cas=1;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(s);
		int len=strlen(s);
		for(int i=0;i<len;i++)
		{
			if(s[i]=='/'&&s[i-1]=='/')
			{
				int j=i+1;p=0;
				while(s[j]!='/'&&s[j]!=':')
					ans[p++]=s[j++];
				break;
			}
		}
		printf("Case #%d: ",cas++);
		for(int i=0;i<p;i++)
			printf("%c",ans[i]);
		puts("");
	}
	return 0;
}


版权声明:本文博客原创文章。博客,未经同意,不得转载。





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4651229.html,如需转载请自行联系原作者


相关文章
|
6月前
|
数据采集 前端开发 数据安全/隐私保护
使用 urllib.parse 模块优雅地处理 URL
使用 urllib.parse 模块优雅地处理 URL
107 9
|
7月前
|
Java 程序员 Apache
有关于异常捕获点滴,plus我也揭揭apache-common ExceptionUtils的短
本文通过示例展示了Java编程中异常处理的几种不当做法,包括无意义地捕获并重新抛出异常、改变异常堆栈信息以及私自“吞噬”异常等,并指出了这些做法可能带来的问题,如增加排障难度等。同时,文章推荐了在捕获异常后打印错误日志的良好习惯,并介绍了如何使用`try...finally`结构进行资源管理和程序状态记录。此外,还特别提到了Apache Commons Lang库中的`ExceptionUtils`工具类在记录异常堆栈信息方面的应用价值,但也对其某些行为提出了疑问,鼓励读者深入探究。
66 0
CTFShow--周末大挑战parse_url篇Writeup
CTFShow--周末大挑战parse_url篇Writeup
177 0
|
10月前
|
存储 XML JSON
@RequestBody、@RequestParam 、@PathVariable @RequestPart 傻傻分不清
@RequestBody、@RequestParam 、@PathVariable @RequestPart 傻傻分不清
592 0
|
C++
【PAT甲级 - C++题解】1071 Speech Patterns
【PAT甲级 - C++题解】1071 Speech Patterns
102 0
|
C++
【PAT甲级 - C++题解】1155 Heap Paths
【PAT甲级 - C++题解】1155 Heap Paths
72 0
|
C++
【PAT甲级 - C++题解】1119 Pre- and Post-order Traversals
【PAT甲级 - C++题解】1119 Pre- and Post-order Traversals
103 0
|
Java
JSP慕课网之application、page、pageContext、config、exception
JSP慕课网之application、page、pageContext、config、exception
122 0