STL--F - Sequence(n*m->之前的最低要求m个月)

简介:
F - Sequence
Time Limit:6000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit   Status

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

感谢http://www.cnblogs.com/372465774y/archive/2012/07/09/2583866.html

做这个题首先思考两个问题



由这两个得出,要求n个数组每一个数组m个值。数组1和数组2的和找出最小的m个,再用来和数组3求和,找到最小的m个,终于得到全部的数组中的最小的m个

因为每一个数组都是有序的,并且我们要求的最小的m个。数组a[i][j]+队列中的值 > 队首的值,那么a[i][j]加上队列中以后的值都会大于队首。对于我们要求解的最小的m个值无意义。队列中保存了当前数组到之前全部数组的最小的m个和,不断更新队列

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
int a[110][2100] , b[2100] ;
priority_queue <int> p ;
int main()
{
    int i , j , k , n , m , t ;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(i = 0 ; i < n ; i++)
        {
            for(j = 0 ; j < m ; j++)
                scanf("%d", &a[i][j]);
            sort(a[i],a[i]+m);
        }
        for(i = 0 ; i < m ; i++)
            p.push(a[0][i]) ;
        for(i = 1 ; i < n ; i++)
        {
            for(j = 0 ; j < m ; j++)
            {
                b[j] = p.top();
                p.pop();
            }
            for(j = 0 ; j < m ; j++)
            {
                for(k = m-1 ; k >= 0 ; k--)
                {
                    if(j == 0)
                        p.push( a[i][j]+b[k] );
                    else
                    {
                        if( a[i][j] + b[k] < p.top() )
                        {
                            p.pop();
                            p.push(a[i][j]+b[k]);
                        }
                        else
                            break;
                    }
                }
            }
        }
        for(j = 0 ; j < m ; j++)
        {
            b[j] = p.top();
            p.pop();
        }
        for(j = m-1 ; j >= 0 ; j--)
        {
            if(j == 0)
                printf("%d\n", b[j]);
            else
                printf("%d ", b[j]);
        }
    }
    return 0;
}


版权声明:转载请注明出处:http://blog.csdn.net/winddreams





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4731914.html,如需转载请自行联系原作者


相关文章
|
5月前
|
存储 编译器 程序员
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南(一)
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南
182 0
|
5月前
|
编解码 算法 程序员
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南(三)
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南
63 0
|
5月前
|
C++ 索引
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南(二)
【C++ 泛型编程 高级篇】 C++ 14 模版元编程 遍历元组 编译期生成整数序列 std::index_sequence和std::make_index_sequence 使用指南
117 0
LeetCode Contest 178-1368. 使网格图至少有一条有效路径的最小代价 Minimum Cost to Make at Least One Valid Path in a Grid
LeetCode Contest 178-1368. 使网格图至少有一条有效路径的最小代价 Minimum Cost to Make at Least One Valid Path in a Grid
LeetCode 1346. 检查整数及其两倍数是否存在 Check If N and Its Double Exist
LeetCode 1346. 检查整数及其两倍数是否存在 Check If N and Its Double Exist
LeetCode 1342. 将数字变成 0 的操作次数 Number of Steps to Reduce a Number to Zero
LeetCode 1342. 将数字变成 0 的操作次数 Number of Steps to Reduce a Number to Zero
|
人工智能 测试技术
PAT (Basic Level) Practice (中文) B1008 数组元素循环右移问题 (20 分)
PAT (Basic Level) Practice (中文) B1008 数组元素循环右移问题 (20 分)
98 0
PAT (Basic Level) Practice (中文) B1008 数组元素循环右移问题 (20 分)
|
索引
LeetCode 599: 两个列表的最小索引总和 Minimum Index Sum of Two Lists
题目: 假设 Andy 和 Doris 想在晚餐时选择一家餐厅,并且他们都有一个表示最喜爱餐厅的列表,每个餐厅的名字用字符串表示。 Suppose Andy and Doris want to choose a restaurant for dinner, and they both have a list of favorite restaurants represented by strings. 你需要帮助他们用最少的索引和找出他们共同喜爱的餐厅。
873 0