HDU3537-Daizhenyang's Coin(博弈SG-打表)

简介:

<span style="color: green; font-family: Arial; font-size: 12px; background-color: rgb(255, 255, 255);">Daizhenyang's Coin
</span>
<span style="color: green; font-family: Arial; font-size: 12px; background-color: rgb(255, 255, 255);">Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)</span>
Total Submission(s): 320    Accepted Submission(s): 146


Problem Description
We know that Daizhenyang is chasing a girlfriend. As we all know, whenever you chase a beautiful girl, there'll always be an opponent, or a rival. In order to take one step ahead in this chasing process, Daizhenyang decided to prove to the girl that he's better and more intelligent than any other chaser. So he arranged a simple game: Coin Flip Game. He invited the girl to be the judge.
In this game, n coins are set in a row, where n is smaller than 10^8. They took turns to flip coins, to flip one coin from head-up to tail-up or the other way around. Each turn, one can choose 1, 2 or 3 coins to flip, but the rightmost selected must be head-up before flipping operation. If one cannot make such a flip, he lost.
As we all know, Daizhenyang is a very smart guy (He's famous for his 26 problems and Graph Theory Unified Theory-Network Flow does it all ). So he will always choose the optimal strategy to win the game. And it's a very very bad news for all the competitors.
But the girl did not want to see that happen so easily, because she's not sure about her feelings towards him. So she wants to make Daizhenyang lose this game. She knows Daizhenyang will be the first to play the game. Your task is to help her determine whether her arrangement is a losable situation for Daizhenyang.
For simplicity, you are only told the position of head-up coins. And due to the girl's complicated emotions, the same coin may be described twice or more times. The other coins are tail-up, of course.
Coins are numbered from left to right, beginning with 0.
 

Input
Multiple test cases, for each test case, the first line contains only one integer n (0<=n<=100), representing the number of head-up coins. The second line has n integers a1, a2 … an (0<=ak<10^8) indicating the An-th coin is head up.
 

Output
Output a line for each test case, if it's a losable situation for Daizhenyang can, print "Yes", otherwise output "No" instead.
 

Sample Input
 
 
0 1 0 4 0 1 2 3
 

Sample Output
 
 
Yes No Yes
翻硬币的经典例子-MOCK-TURTLES
打表发现:
x: 0 1 2 3 4 5 6 7...
g(x): 1 2 4 7 8 11 13 14...
发现x化作2进制1的个数为奇数时。g(x)= 2*x 否则 g(x) = 2*x+1 SG和即是答案。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
using namespace std;
int n;
set<int>st;
int main(){

    while(~scanf("%d",&n)){
        int ans = 0;
        st.clear();
        for(int i = 0; i < n; i++){
            int t;
            scanf("%d",&t);
            if(st.count(t)==0){
                if(t==0) ans ^= 1;
                else{
                    int k = t,cnt = 0;
                    while(k){
                        k = k&(k-1);
                        cnt++;
                    }
                    if(cnt%2==0) ans ^= (2*t+1);
                    else ans ^= 2*t;

                }
                st.insert(t);
            }

        }
        if(ans==0){
            cout<<"Yes"<<endl;
        }else{
            cout<<"No"<<endl;
        }
    }
    return 0;
}






本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5077760.html,如需转载请自行联系原作者

相关文章
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
58 0
【CCCC】L3-022 地铁一日游 (30分),floyd+大模拟
【CCCC】L3-022 地铁一日游 (30分),floyd+大模拟
266 0
HDU1276士兵队列训练问题
HDU1276士兵队列训练问题
hdu 1276 士兵队列训练问题
hdu 1276 士兵队列训练问题
416 0
忆pta水题
本题要求编写程序,先将输入的一系列整数中的最小值与第一个数交换,然后将最大值与最后一个数交换,最后输出交换后的序列。 注意:题目保证最大和最小值都是唯一的。 输入格式: 输入在第一行中给出一个正整数N(≤10),第二行给出N个整数,数字间以空格分隔。 输出格式: 在一行中顺序输出交换后的序列,每个整数后跟一个空格。 输入样例: 5 8 2 5 1 4 结尾无空行 输出样例: 1 2 5 4 8 
HDU-1370,Biorhythms(中国剩余定理)
本题主要就是应用中国剩余定理。
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
Java BI 机器学习/深度学习