9度oj 题目1001:A+B for Matrices【水题】

简介: 题目1001:A+B for Matrices 时间限制:1 秒 内存限制:32 兆 特殊判题:否 提交:13653 解决:5575 题目描述:     This time, you are supposed to fin...
题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:13653

解决:5575

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题
题意:给出2个n*m的矩阵,然后相加,判断有多少行或者列的值均为0
import java.util.Scanner;
public class Main 
{
    public static void main(String[] args) 
    {
        Scanner cin = new Scanner(System.in);
        int [][]a = new int[20][20];
        int n,m;
        while(1>0)
        {
            n=cin.nextInt();
            if(n==0)return ;
            m=cin.nextInt();
            for (int i = 0; i<n; i++)
            {
                for (int j = 0; j < m; j++)
                {
                    a[i][j] = cin.nextInt();
                }
            }
            for (int i = 0; i<n; i++)
            {
                for (int j = 0; j < m; j++)
                {
                    int t = cin.nextInt();
                    a[i][j] +=t; 
                }
            }
            int count = 0;
            for(int i=0,j=0;i<n;i++)
            {
                for(j=0;j<m;j++)
                {
                    if(a[i][j]!=0)
                        break;
                }
                if(j==m) count++;
            }
            for(int i=0,j=0;i<m;i++)
            {
                for(j=0;j<n;j++)
                {
                    if(a[j][i]!=0)
                        break;
                }
                if(j==n) count++;
            }
            System.out.println(count);
        } 
    }  
}
目录
相关文章
|
3月前
|
C++
【洛谷 P1706】全排列问题 题解(全排列)
该问题要求按字典序输出从1到n的所有不重复排列。输入为整数n,输出为每行一个的数字序列,每个数字占5个宽度。样例输入3,输出6行全排列。代码使用C++,通过`next_permutation`函数生成所有排列。注意n的范围是1到9。
18 0
|
4月前
|
C++ 算法 存储
力扣 C++|一题多解之动态规划专题(2)
力扣 C++|一题多解之动态规划专题(2)
54 0
力扣 C++|一题多解之动态规划专题(2)
|
4月前
|
算法 C++ 机器人
力扣 C++|一题多解之动态规划专题(1)
力扣 C++|一题多解之动态规划专题(1)
57 0
力扣 C++|一题多解之动态规划专题(1)
【力扣每日一题:2-20】697. 数组的度【简单】
【力扣每日一题:2-20】697. 数组的度【简单】
【LeetCode-每日一题】-16. 最接近的三数之和
【LeetCode-每日一题】-16. 最接近的三数之和
|
人工智能 移动开发 机器人
蓝桥杯AcWing 题目题解 - 二分与前缀和、差分
蓝桥杯AcWing 题目题解 - 二分与前缀和、差分
127 0
蓝桥杯AcWing 题目题解 - 递归与递推
蓝桥杯AcWing 题目题解 - 递归与递推
|
算法
【AcWing&&牛客】打表找规律
【AcWing&&牛客】打表找规律
79 0
|
算法 Go Python
LeetCode46:全排列(八皇后)
LeetCode46:全排列(八皇后)
LeetCode46:全排列(八皇后)