9度oj 题目1004:Median【排序水题】

简介: 题目1004:Median 时间限制:1 秒 内存限制:32 兆 特殊判题:否 提交:12541 解决:3434 题目描述:     Given an increasing sequence S of N integers, the median is the number at the middle position.
题目1004:Median

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:12541

解决:3434

题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13
来源:
2011年浙江大学计算机及软件工程研究生机试真题
题意:给出2个数组,合并后求中位数,如果是偶数个,输出中间2个中的第一个。
import java.util.Arrays;
import java.util.Scanner;
public class Main 
{
	public static void main(String[] args) 
	{
		Scanner cin = new Scanner(System.in);
		while(cin.hasNext())
		{
			int n,m,i;
			long[] a = new long[2000100];
			n = cin.nextInt();
			for (i = 0; i < n; i++)
			{
				a[i] = cin.nextLong();
			}
			m = cin.nextInt();
			n+=m;
			for (; i < n; i++)
			{
				a[i] = cin.nextLong();
			}
			Arrays.sort(a,0,n);
			System.out.println(a[(n-1)/2]);
		}
		cin.close();
	}
}
目录
相关文章
|
缓存 算法 Java
【手绘算法】力扣 1 两数之和(Two Sum)
Hi,大家好,我是Tom。一个美术生转到Java开发的程序员。从今天开始,我将带大家每天刷一道题。我会用手绘的方式给大家讲解解题思路。在解题过程中,也会手写一些伪代码。当然,如果想要完整的源码的话,可以到我的个人主页简介中获取。 今天给大家分享的是力扣启蒙题第1题,求两数之和。虽然很简单,但是它的通过率只有52%。
105 0
|
3月前
lanqiao OJ k倍区间
lanqiao OJ k倍区间
13 0
|
8月前
|
C语言
pta 浙大版《C语言程序设计(第3版)》题目集 习题6-6 使用函数输出一个整数的逆序数 (20分)
pta 浙大版《C语言程序设计(第3版)》题目集 习题6-6 使用函数输出一个整数的逆序数 (20分)
|
8月前
|
人工智能
PTA-排序问题
排序问题
53 0
|
容器
华为机试HJ60:查找组成一个偶数最接近的两个素数
华为机试HJ60:查找组成一个偶数最接近的两个素数
华为机试HJ37:统计每个月兔子的总数(斐波那契数列)
华为机试HJ37:统计每个月兔子的总数(斐波那契数列)
PTA 7-4 素数等差数列 (20 分)
2004 年,陶哲轩(Terence Tao)和本·格林(Ben Green)证明了:对于任意大的 n,均存在 n 项全由素数组成的等差数列。
128 0
PTA 7-4 最近的斐波那契数 (20 分)
斐波那契数列 F n ​ 的定义为:对 n≥0 有 F n+2 ​ =F n+1 ​ +F n ​ ,初始值为 F 0 ​ =0 和 F 1 ​ =1。
131 0
PTA 1056 组合数的和 (15 分)
给定 N 个非 0 的个位数字,用其中任意 2 个数字都可以组合成 1 个 2 位的数字。要求所有可能组合出来的 2 位数字的和。
131 0