HDOJ 2057 A + B Again

简介: Problem Description There must be many A + B problems in our HDOJ , now a new one is coming.

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            long str1 = sc.nextLong(16);
            long str2 = sc.nextLong(16);
            long a = str1+str2;
            if(a<0){
                //System.out.println(a);
                a=-a;
                //System.out.println(a);
                System.out.println("-"+Long.toHexString(a).toUpperCase());
            }else{
                System.out.println(Long.toHexString(a).toUpperCase());
            }
        }
    }

}
目录
相关文章
|
7月前
|
Java C++
hdoj 1715 大菲波数
先java代码
31 1
HDOJ 1323 Perfection(简单题)
HDOJ 1323 Perfection(简单题)
102 0
HDOJ 2034 人见人爱A-B
HDOJ 2034 人见人爱A-B
110 0
HDOJ 2033 人见人爱A+B
HDOJ 2033 人见人爱A+B
130 0
|
Java
HDOJ 1715 大菲波数
HDOJ 1715 大菲波数
90 0
HDOJ 2040 亲和数
HDOJ 2040 亲和数
90 0
|
人工智能 Java BI