HDOJ 2057 A + B Again

简介: Problem Description There must be many A + B problems in our HDOJ , now a new one is coming.

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            long str1 = sc.nextLong(16);
            long str2 = sc.nextLong(16);
            long a = str1+str2;
            if(a<0){
                //System.out.println(a);
                a=-a;
                //System.out.println(a);
                System.out.println("-"+Long.toHexString(a).toUpperCase());
            }else{
                System.out.println(Long.toHexString(a).toUpperCase());
            }
        }
    }

}
目录
相关文章
HDOJ 1214 圆桌会议
HDOJ 1214 圆桌会议
105 0
HDOJ 1303 Doubles(简单题)
HDOJ 1303 Doubles(简单题)
107 0
HDOJ 2040 亲和数
HDOJ 2040 亲和数
132 0
HDOJ 2019 数列有序!
HDOJ 2019 数列有序!
138 0
|
机器学习/深度学习 网络协议 缓存
|
Java BI 数据安全/隐私保护
HDOJ 2100 Lovekey
Problem Description XYZ-26进制数是一个每位都是大写字母的数字。 A、B、C、…、X、Y、Z 分别依次代表一个0 ~ 25 的数字,一个 n 位的26进制数转化成是10进制的规则如下 A0A1A2A3…An-1 的每一位代表的数字为a0a1a2a3…...
748 0
HDOJ 2050 折线分割平面
Problem Description 我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。
998 0
HDOJ 2004 成绩转换
Problem Description 输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下: 90~100为A; 80~89为B; 70~79为C; 60~69为D; 0~59为E; Input 输入数据有多组,每组占一行,由一个整数组成。
900 0