HDOJ 2802 F(N)

简介: Problem Description Giving the N, can you tell me the answer of F(N)?Input Each test case contains a single integer N(1

Problem Description

Giving the N, can you tell me the answer of F(N)?

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.

Output
For each test case, output on a line the value of the F(N)%2009.

Sample Input
1
2
3
0

Sample Output
1
7
20

一般这种让根据公式求出对应项的值得题都有规律 (有一个循环,此题的循环为4018(注意 这种有循环规律的是让你输出对应项对某个数取余后的题))可以先打表写出有限个数的结果,再观察规律,或者直接写代码判断是否进入了循环。

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    static int[] f = new int[10000];
    public static void main(String[] args) {
        f[1]=1;
        f[2]=7;
        for(int i=3;i<=4018;i++){
            f[i] = (f[i-2]-((i-1)*(i-1)*(i-1))+(i*i*i))%2009;
            //System.out.println(i+" "+f[i]);
        }
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0)
                return ;
//          for(int i=3;i<100000;i+=2){
//              if(f[i]==1&&f[i+1]==7){
//                  System.out.println(i-1);
//                  break;
//              }
//          }
            //判断多久开始循环
            System.out.println(f[n%4018]);
        }

    }

}
目录
相关文章
hdoj 2089 不要62
这题数据量相对比较小,可以暴力打表解决。不过我这里用数位dp 刚开始学数位dp,参考了别人的代码。
58 0
HDOJ 2004 成绩转换
HDOJ 2004 成绩转换
98 0
|
人工智能 Java BI
|
Java 机器学习/深度学习
HDOJ 1412 {A} + {B}
Problem Description 给你两个集合,要求{A} + {B}. 注:同一个集合中不会有两个相同的元素. Input 每组输入数据分为三行,第一行有两个数字n,m(0 < n,m marr[mid]) { System.
781 0
|
Java BI 数据安全/隐私保护
HDOJ 2100 Lovekey
Problem Description XYZ-26进制数是一个每位都是大写字母的数字。 A、B、C、…、X、Y、Z 分别依次代表一个0 ~ 25 的数字,一个 n 位的26进制数转化成是10进制的规则如下 A0A1A2A3…An-1 的每一位代表的数字为a0a1a2a3…...
747 0
|
机器学习/深度学习
HDOJ 2074 叠筐
Problem Description 需要的时候,就把一个个大小差一圈的筐叠上去,使得从上往下看时,边筐花色交错。这个工作现在要让计算机来完成,得看你的了。 Input 输入是一个个的三元组,分别是,外筐尺寸n(n为满足0< n< 80的奇整数),中心花色字符,外筐花色字符,后二者都为ASCII可见字符; Output 输出叠在一起的筐图案,中心花色与外筐花色字符从内层起交错相叠,多筐相叠时,最外筐的角总是被打磨掉。
852 0
|
人工智能
HDOJ 2019 数列有序!
Problem Description 有n(n
824 0