Struts 2再爆高危漏洞CVE-2017-5638 绿盟科技发布免费扫描工具及产品升级包-阿里云开发者社区

开发者社区> 安全> 正文

Struts 2再爆高危漏洞CVE-2017-5638 绿盟科技发布免费扫描工具及产品升级包

简介:

Apache Structs2的Jakarta Multipart parser插件存在远程代码执行漏洞,漏洞编号为CVE-2017-5638。cwiki.apache.org公告了这个信息。

绿盟科技发布免费扫描工具及产品升级包

绿盟科技紧急发布了在线免费扫描工具,同时发布了产品升级包,包括绿盟远程安全评估系统RSAS V6插件升级包,及WEB应用漏洞扫描系统WVSS V6插件设计包

Struts 2漏洞CVE-2017-5638 扫描工具

绿盟云已上线紧急扫描,地址:

http://t.cn/RipBq1c

再增加一个手机上使用的版本,

https://cloud.nsfocus.com/megi/hole_list.html

Struts2.png

Struts 2漏洞CVE-2017-5638产品升级包

  • RSAS V6已发布插件升级包 V6.0R02F00.0412
  • WVSS V6已发布插件升级包 V6.0R03F00.70

各升级包下载地址,参见

http://update.nsfocus.com/

远程代码执行漏洞rce漏洞是什么

通俗解释

远程执行代码是一种比较严重的漏洞,举个例子,攻击者把恶意代码存放在一个网页上面,然后你的电脑里面装了带漏洞的软件,当你访问那个网页的时候,这个漏洞就会触发,恶意代码就会执行。 恶意代码通常会后台下载一个文件然后执行它,而它下载的通常是木马,也就是说你一访问这个网页就会中毒,大部分“网马”指的就是这类

科学解释

远程命令执行漏洞,用户通过浏览器提交执行命令,由于服务器端没有针对执行函数做过滤,导致在没有指定绝对路径的情况下就执行命令,可能会允许攻击者通过改变 $PATH 或程序执行环境的其他方面来执行一个恶意构造的代码.

绿盟科技发布 Apache Struts2 远程代码执行漏洞(S2-045)威胁预警通告

通告全文如下

Apache Structs2的Jakarta Multipart parser插件存在远程代码执行漏洞,漏洞编号为CVE-2017-5638。攻击者可以在使用该插件上传文件时,修改HTTP请求头中的Content-Type值来触发该漏洞,导致远程执行代码。

相关链接如下:

https://cwiki.apache.org/confluence/display/WW/S2-045?from=timeline&isappinstalled=0

绿盟科技威胁预警级别

高级:影响范围比较广,危害严重,利用难度较低,7*24小时内部应急跟踪,24小时内完成技术分析、产品升级和防护方案。

绿盟科技威胁事件定级标准

级别 描述

  • 高 影响范围比较广,危害严重,利用难度较低,7*24小时内部应急跟踪,24小时内完成技术分析、产品升级和防护方案。
  • 中 影响范围可控,危害程度可控,利用难度较高,7*8小时内部应急跟踪,72小时内完成技术分析、产品升级和防护方案。
  • 低 影响较小,危害程度较小。

影响范围

影响的版本

  • Struts 2.3.5 - Struts 2.3.31
  • Struts 2.5 - Struts 2.5.10

不受影响的版本

  • Struts 2.3.32
  • Struts 2.5.10.1

规避方案

如果用户正在使用受影响版本的插件:

  • 建议用户升级到不受影响的版本(Struts 2.3.32或Struts 2.5.10.1),建议在升级前做好数据备份。
  • 改用其他Multipart parser应用。

绿盟科技安全团队会持续关注事态变化,后续会发布详细的分析报告、产品升级及解决方案,请广大用户随时关注。

绿盟科技声明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。



原文发布时间:2017年3月24日

本文由:绿盟科技发布,版权归属于原作者

原文链接:http://toutiao.secjia.com/struts2-rce-high-risk-vulnerability-cve-2017-5638

本文来自云栖社区合作伙伴安全加,了解相关信息可以关注安全加网站

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
+ 订阅

云安全开发者的大本营

其他文章