poj-1611-The Suspects

简介: poj-1611-The Suspects


The Suspects

Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 28243   Accepted: 13760

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

Source

Asia Kaohsiung 2003



#include<cstdio>
#include<cstring>
#define M 30000+10
int p[M],num[M];
int find(int x)
{
  if(x!=p[x])
        p[x]=find(p[x]);
  return p[x];
}
void he(int x,int y)
{
  int x1=find(x);
  int y1=find(y);
    if(x1!=y1)
    {
      p[y1]=x1;
      num[x1]+=num[y1];
  }
}
int main()
{
  int n,m,a;
  while(scanf("%d%d",&n,&m),n|m)
  {
    for(int i=0;i<n;i++)
    {
      p[i]=i;
      num[i]=1;
    }
    for(int i = 1; i <= m; i++)
    {
      scanf("%d", &a);
      int *stu = new int[a]; //动态数组 
      for(int j = 0; j < a; ++j)
      {
        scanf("%d", &stu[j]);
        if(j != 0)
          he(stu[j - 1], stu[j]);
      }
      delete(stu);//数组清零 
    }
    printf("%d\n", num[find(0)]);
  }
  return 0;
}








目录
相关文章
|
8月前
POJ-2245-Lotto
POJ-2245-Lotto
42 0
|
8月前
|
算法 数据建模
Poj 3169(差分约束系统)
Poj 3169(差分约束系统)
38 0
|
算法框架/工具
POJ 2262 Goldbach's Conjecture
POJ 2262 Goldbach's Conjecture
146 0
POJ 1012 Joseph
Joseph Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 53862   Accepted: 20551 Description The Joseph's problem is notoriously known.
846 0
POJ 1067 取石子游戏
取石子游戏 Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 40917   Accepted: 13826 Description 有两堆石子,数量任意,可以不同。
1125 0
|
人工智能
POJ 2531
初学dfs参考别人代码,如有雷同,见怪不怪。#include using namespace std; int aa[25][25]; int maxa=0; int step[25]={0},n; void dfs(int a,int b) { int t=b; step...
719 0
poj 1455
Description n participants of > sit around the table. Each minute one pair of neighbors can change their places.
624 0
poj-2551-ones
Description Given any integer 0
780 0
POJ 2487 Stamps
Description Background Everybody hates Raymond. He’s the largest stamp collector on planet earth and because of that he always makes fun of all the others at the stamp collector parties.
1073 0
POJ 2027 No Brainer
Problem Description Zombies love to eat brains. Yum. Input The first line contains a single integer n indicating the number of data sets.
872 0