SDUT JAVAlab3.5

简介: SDUT JAVAlab3.5

7-5 sdut-JAVA-Exam Scores

分数 12

 

全屏浏览

 

切换布局

作者 马新娟

单位 山东理工大学

Write a program that requests an exam score and displays the corresponding letter grade using the information in the following table.If the exam score is less than 0 or more than 100,please display “Invalid exam score - a valid score is a whole number in the range 0 to 100." information.

 

Input Specification:

an exam score.

Output Specification:

displays the corresponding letter grade using the information in the following table.

Sample Input:

90

Sample Output:

Exam grade is A

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

import java.util.Scanner;
public class Main{
  public static void main(String [] args)
  {
    Scanner sc=new Scanner(System.in);
    double n;
    n=sc.nextInt();
    if(n>100||n<0)
    {
      System.out.println("Invalid exam score - a valid score is a whole number in the range 0 to 100.");
    }
    else if(n>=90&&n<=100)
    {
      System.out.println("Exam grade is A");
    }
    else if(n>=80&&n<=89)
    {
      System.out.println("Exam grade is B");
    }
    else if(n>=70&&n<=79)
    {
      System.out.println("Exam grade is C");
    }
    else if(n>=60&&n<=69)
    {
      System.out.println("Exam grade is D");
    }
    else if(n>=0&&n<=59)
    {
      System.out.println("Exam grade is F");
    }
  }
}

 

 


目录
相关文章
|
6月前
7-2 sdut-C语言实验-删数问题(贪心法二)
7-2 sdut-C语言实验-删数问题(贪心法二)
43 2
|
6月前
SDUT 链表9-------7-9 sdut-C语言实验-约瑟夫问题
SDUT 链表9-------7-9 sdut-C语言实验-约瑟夫问题
31 0
|
6月前
|
BI
7-7 sdut-C语言实验-上升子序列
7-7 sdut-C语言实验-上升子序列
32 0
|
6月前
递推7-2 sdut-C语言实验-养兔子分数
递推7-2 sdut-C语言实验-养兔子分数
28 0
|
6月前
sdut 链表7
sdut 链表7
34 0
|
6月前
7-4 sdut-C语言实验-区间覆盖问题
7-4 sdut-C语言实验-区间覆盖问题
41 2
|
6月前
|
机器学习/深度学习
7-2 sdut-C语言实验-刘老师的要求之踩方格
7-2 sdut-C语言实验-刘老师的要求之踩方格
47 1
|
6月前
|
算法
7-2 sdut-C语言实验-数字三角形问题
7-2 sdut-C语言实验-数字三角形问题
35 1
|
6月前
7-6 sdut-C语言实验-爬楼梯
7-6 sdut-C语言实验-爬楼梯
29 0
|
6月前
7-8 sdut-C语言实验-全排列问题
7-8 sdut-C语言实验-全排列问题
45 0