ZigZagging on a Tree二叉树蛇形层次遍历(Java语言)

简介: ZigZagging on a Tree二叉树蛇形层次遍历(Java语言)

题目描述:

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

4726b256e87946f188365e2f21fc5300.png


Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.


Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.


Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

解题思路:

根据中序和后序创建二叉树,最后蛇形层次遍历(遍历一层就开始反转一次,Java中使用了LinkedList进行存储处理)

代码中有根据中序和后序创建二叉树的模板,有层次遍历的模板;

先序和中序创建二叉树的模板参考先序和中序创建二叉树

代码:

package text_9_25;

import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class ZigZaggingOnATree {
  public static void main(String[] args) {
    // TODO Auto-generated method stub
    Scanner scanner = new Scanner(System.in);
    int n = scanner.nextInt();
    int in[] = new int[n];
    int post[] = new int[n];
    for(int i=0;i<n;i++)
      in[i] = scanner.nextInt();
    for(int i=0;i<n;i++)
      post[i] = scanner.nextInt();
    //创建二叉树
    Node root = BuildTree(in, 0, n-1, post, 0, n-1);
    
    //蛇形层次遍历
    PrintLevelOrder(root);

    
  }
  
  public static Node BuildTree(int in[],int ibegin,int iend,int post[],int pbegin,int pend) {
    if(ibegin>iend||pbegin>pend) return null;
    Node root = new Node(post[pend]);
    for(int i=ibegin;i<=iend;i++) {
      if(post[pend]==in[i]) {
        root.left = BuildTree(in, ibegin, i-1, post, pbegin, pbegin-ibegin+i-1);
        root.right = BuildTree(in, i+1, iend, post, pbegin-ibegin+i, pend-1);
      }
    }
    return root;
  }
  public static void PrintLevelOrder(Node root) {
    boolean reversed = false;//反转标志
    Queue<Node> queue = new LinkedList<>();
    queue.add(root);
    int flag=1;//用于输出格式控制
    while(!queue.isEmpty()) {
      int size = queue.size();//当前层的节点数
      LinkedList<Integer> link = new LinkedList<>();//保存当前层结果,LinkedList可以前后插入
      for(int i=0;i<size;i++) {  //对应每一层
        Node temp = queue.poll();
        if(reversed) link.add(temp.data);
        else link.addFirst(temp.data);
        
        if(temp.left!=null) queue.add(temp.left);
        if(temp.right!=null) queue.add(temp.right);
      }
//      System.out.println(size);
      for(int j=0;j<link.size();j++) {
        if(flag==1) {
          System.out.print(link.get(j));
          flag=0;
        }
        else System.out.print(" "+link.get(j));
      }
      reversed =!reversed;  //每次反转
    }
  }

}
class Node{   //树节点类
  public int data;
  public Node left;
  public Node right;
  public Node(int data){
    this.data = data;
    left = right = null;
  }
}

相关文章
|
1月前
|
存储 人工智能 算法
数据结构与算法细节篇之最短路径问题:Dijkstra和Floyd算法详细描述,java语言实现。
这篇文章详细介绍了Dijkstra和Floyd算法,这两种算法分别用于解决单源和多源最短路径问题,并且提供了Java语言的实现代码。
69 3
数据结构与算法细节篇之最短路径问题:Dijkstra和Floyd算法详细描述,java语言实现。
|
11天前
|
SQL 安全 Java
安全问题已经成为软件开发中不可忽视的重要议题。对于使用Java语言开发的应用程序来说,安全性更是至关重要
在当今网络环境下,Java应用的安全性至关重要。本文深入探讨了Java安全编程的最佳实践,包括代码审查、输入验证、输出编码、访问控制和加密技术等,帮助开发者构建安全可靠的应用。通过掌握相关技术和工具,开发者可以有效防范安全威胁,确保应用的安全性。
24 4
|
1月前
|
Java 程序员 编译器
在Java编程中,保留字(如class、int、for等)是具有特定语法意义的预定义词汇,被语言本身占用,不能用作变量名、方法名或类名。
在Java编程中,保留字(如class、int、for等)是具有特定语法意义的预定义词汇,被语言本身占用,不能用作变量名、方法名或类名。本文通过示例详细解析了保留字的定义、作用及与自定义标识符的区别,帮助开发者避免因误用保留字而导致的编译错误,确保代码的正确性和可读性。
43 3
|
1月前
|
移动开发 Java 大数据
深入探索Java语言的核心优势与现代应用实践
【10月更文挑战第10天】深入探索Java语言的核心优势与现代应用实践
51 4
|
1月前
|
Java
【用Java学习数据结构系列】震惊,二叉树原来是要这么学习的(二)
【用Java学习数据结构系列】震惊,二叉树原来是要这么学习的(二)
27 1
|
1月前
|
算法 Java C语言
【用Java学习数据结构系列】震惊,二叉树原来是要这么学习的(一)
【用Java学习数据结构系列】震惊,二叉树原来是要这么学习的(一)
24 1
|
23天前
|
算法 Java
JAVA 二叉树面试题
JAVA 二叉树面试题
14 0
|
1月前
|
分布式计算 安全 Java
Java语言的特点?
Java语言的特点?
|
Java
java实现简单的二叉树ADT
java实现简单的二叉树ADT
159 0
|
Java 程序员
java实现简单二叉树
java实现简单二叉树
387 0
java实现简单二叉树