Hopscotch(POJ-3050)

简介: Hopscotch(POJ-3050)

题目:

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit

(potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1…5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

解题思路:深搜的题目,分别从5^5的矩阵各个顶点上下左右出发,然后走六步组成一个六位数,判断能组成多少个不同的六位数

注意:每组成一个六位数就要标记一下,所以数组至少要开七位。

程序代码:

#include<stdio.h>
#include<string.h>
int n=0;
int a[15][15],book[15][15],f[10000010];//因为要组成六位数,所以数组至少要开七位
int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
void dfs(int x,int y,int t,int sum)
{
  int i,j,k,tx,ty;
  if(t==5)
  {
    if(f[sum]==0)
      n++;
    f[sum]=1;
    return;
  }
  for(k=0;k<=3;k++)
  {
    tx=x+next[k][0];
    ty=y+next[k][1];
    if(tx<1||tx>5||ty<1||ty>5)
      continue;
    dfs(tx,ty,t+1,sum*10+a[tx][ty]);
  }
  return;
}
int main()
{
  int i,j,k,t,sum;
  for(i=1;i<=5;i++)
    for(j=1;j<=5;j++)
      scanf("%d",&a[i][j]);
  for(i=1;i<=5;i++)
    for(j=1;j<=5;j++)
      dfs(i,j,0,a[i][j]);
  printf("%d\n",n);
  return 0;   
} 
相关文章
|
9月前
|
容器
POJ 3640 Conformity
POJ 3640 Conformity
41 0
|
C语言
poj 2503 查字典
Description You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language.
839 0
|
算法 计算机视觉
最小割-poj-2914
poj-2914-Minimum Cut Description Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must b
1534 0