POJ 1936 All in All

简介: POJ 1936 All in All

Description


You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.


Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input


The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output


For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.

Sample Input


sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output


Yes

No

Yes

No

题目要求就是在s2中找字串s1!

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
char a[100005],b[100005];
int main()
{
    while(~scanf("%s",a)){
        scanf("%s",b);
        int a_length = strlen(a);
        int b_length = strlen(b);
        int a1,b1=0;
        int i;
        for(i=0;i<a_length;i++){
                bool flag=false;
            for(int j=b1;j<b_length;j++){
                if(a[i]==b[j]){
                    b1=j+1;
                    flag=true;
                    break;
                }
            }
            if(!flag)
                break;
        }
        if(i==a_length)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
目录
相关文章
|
2月前
|
算法
Wormholes—POJ3259
Wormholes—POJ3259
|
算法框架/工具
POJ 2262 Goldbach's Conjecture
POJ 2262 Goldbach's Conjecture
122 0
poj 3620
题意:给出一个矩阵,其中有些格子干燥、有些潮湿。       如果一个潮湿的格子的相邻的四个方向有格子也是潮湿的,那么它们就可以构成更大       的湖泊,求最大的湖泊。       也就是求出最大的连在一块儿的潮湿的格子的数目。
560 0
poj-2551-ones
Description Given any integer 0
756 0
|
人工智能
POJ 1936 All in All
Description You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way.
770 0
|
机器学习/深度学习
|
机器学习/深度学习 Windows
|
机器学习/深度学习