配置本地MAC镜像示例

简介: 1. 创建VLAN10,将Switch与主机相连的接口加入VLAN10,实现主机与Switch间的二层互通。2. 配置接口GE0/0/4为本地观察端口,负责向Server转发镜像报文。3. 在VLAN10内配置MAC镜像,将VLAN10内指定MAC地址的主机访问Internet的流量复制一份到本地观察端口。


配置本地MAC镜像示例

组网图形

图1 配置本地MAC镜像组网图

image.png

  • 本地MAC镜像简介
  • 配置注意事项
  • 组网需求
  • 配置思路
  • 操作步骤
  • 配置文件

本地MAC镜像简介

本地MAC镜像是指观察端口与监控设备直连,观察端口直接将包含指定MAC地址的报文转发到相连的监控设备进行分析。

配置注意事项

  • 观察端口专门用于镜像报文的转发,因此不要在上面配置其他业务,防止镜像报文与其他业务的数据报文在观察端口上同时转发会互相影响。尤其是当某一接口为Eth-Trunk接口的成员接口时,不要配置该成员接口为观察端口,如果确实需要,请确保该成员接口所承载的业务流量以及镜像流量占用的带宽未超过该接口带宽。
  • 在设备上应用镜像功能时,如果镜像过多,会占用较多的设备内部转发带宽,影响其他业务转发。另外,如果镜像端口的带宽大于观察端口的带宽,比如,镜像端口的带宽是1000Mbit/s,观察端口的带宽是100Mbit/s,会导致观察端口因带宽不足而不能及时转发全部的镜像报文,发生丢包。
  • MAC镜像只支持入方向镜像。
  • 本举例适用于如下产品和版本:
  • 框式交换机:V200R019C10及后续版本
  • S5730-HI、S5731-H、S5731S-H、S5731-S、S5731S-S、S5732-H、S6720-HI、S6730-H、S6730-S、S6730S-S:V200R019C10及后续版本
  • S2700-52P-EI、S2700-52P-PWR-EI、S2720-EI、S2750-EI、S3700-SI、S3700-EI、S3700-HI:适用版本请参见“案例适用的产品和版本说明”中的表1
  • S5700-LI、S5700S-LI、S5710-C-LI、S5710-X-LI、S5700-SI、S5700-EI、S5710-EI、S5700-HI、S5710-HI、S5720-LI、S5720S-LI、S5720-SI、S5720S-SI、S5720I-SI、S5730-SI、S5730S-EI、S5720-EI、S2730S-S、S5735-L-I、S5735-L1、S300、S5735-L、S5735S-L1、S5735S-L、S5735S-L-M、S500、S5735-S、S5735S-S、S5735S-H、S5736-S、S5735-S-I、S5731-H-K、S5732-H-K:适用版本请参见“案例适用的产品和版本说明”中的表1
  • S6700-EI、S6720-LI、S6720S-LI、S6720-SI、S6720S-SI、S6720-EI、S6720S-EI、S6730-H-K、S6730S-H:适用版本请参见“案例适用的产品和版本说明”中的表1

组网需求

图1所示,某公司所有主机通过Switch与外部Internet通信,并且同属于VLAN10。监控设备Server与Switch直连。

现在希望通过Server对MAC地址为0001-0001-0001的主机访问Internet的流量进行监控。

配置思路

  1. 创建VLAN10,将Switch与主机相连的接口加入VLAN10,实现主机与Switch间的二层互通。
  2. 配置接口GE0/0/4为本地观察端口,负责向Server转发镜像报文。
  3. 在VLAN10内配置MAC镜像,将VLAN10内指定MAC地址的主机访问Internet的流量复制一份到本地观察端口。

操作步骤

  1. 配置接口加入VLAN# 在Switch上创建VLAN10,配置接口GE0/0/1~GE0/0/3加入VLAN10。

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 10

[Switch] interface gigabitethernet 0/0/1

[Switch-GigabitEthernet0/0/1] port link-type access     //设置主机侧接口链路类型为access,接口缺省链路类型不是access口

[Switch-GigabitEthernet0/0/1] port default vlan 10

[Switch-GigabitEthernet0/0/1] quit

[Switch] interface gigabitethernet 0/0/2

[Switch-GigabitEthernet0/0/2] port link-type access     //设置主机侧接口链路类型为access,接口缺省链路类型不是access口

[Switch-GigabitEthernet0/0/2] port default vlan 10

[Switch-GigabitEthernet0/0/2] quit

[Switch] interface gigabitethernet 0/0/3

[Switch-GigabitEthernet0/0/3] port link-type access     //设置主机侧接口链路类型为access,接口缺省链路类型不是access口

[Switch-GigabitEthernet0/0/3] port default vlan 10

[Switch-GigabitEthernet0/0/3] quit

  1. 配置观察端口# 在Switch上配置接口GE0/0/4为本地观察端口。

[Switch] observe-port 1 interface gigabitethernet 0/0/4     //配置GE0/0/4为本地观察端口,观察端口索引为1

  1. 配置MAC地址镜像# 在Switch上的VLAN10内配置MAC地址镜像,将其入方向绑定到本地观察端口,即将VLAN10内所有端口接收到的MAC地址为0001-0001-0001的报文复制一份到本地观察端口。

[Switch] vlan 10

[Switch-vlan10] mac-mirroring 0001-0001-0001 to observe-port 1 inbound     //VLAN10内所有接口入方向的MAC地址为0001-0001-0001报文镜像到索引为1的观察端口上

[Switch-vlan10] return

  1. 验证配置结果# 查看观察端口的配置情况。

<Switch> display observe-port

 ----------------------------------------------------------------------

 Index          : 1

 Untag-packet   : No

 Forwarding     : No

 Interface      : GigabitEthernet0/0/4

 ----------------------------------------------------------------------

  1. # 查看镜像端口的配置情况。

<Switch> display port-mirroring

 ----------------------------------------------------------------------

 Observe-port 1 : GigabitEthernet0/0/4

 ----------------------------------------------------------------------

 Mac-mirror:

 ----------------------------------------------------------------------

 Mirror-mac       Vlan    Direction     Observe-port

 ----------------------------------------------------------------------

 0001-0001-0001   10      Inbound       Observe-port 1

 ----------------------------------------------------------------------

配置文件

Switch的配置文件

#

sysname Switch

#

vlan batch 10

#

observe-port 1 interface GigabitEthernet0/0/4

#

vlan 10

mac-mirroring 0001-0001-0001 to observe-port 1 inbound

#

interface GigabitEthernet0/0/1

port link-type access

port default vlan 10

#

interface GigabitEthernet0/0/2

port link-type access

port default vlan 10

#

interface GigabitEthernet0/0/3

port link-type access

port default vlan 10

#

return


相关文章
|
15天前
|
监控 网络虚拟化
配置远程MAC镜像示例
配置远程MAC镜像示例
|
15天前
|
定位技术
Mac电脑报错“托管配置文件格式不正确”的解决方法
Mac电脑报错“托管配置文件格式不正确”的解决方法
175 1
|
19小时前
|
Docker 容器
mac构建Docker镜像报错failed to solve with frontend dockerfile.v0: failed to create LLB definition: unexpec
mac构建Docker镜像报错failed to solve with frontend dockerfile.v0: failed to create LLB definition: unexpec
3 0
|
15天前
|
存储 Ubuntu Shell
mac docker镜像在哪个文件夹
【2月更文挑战第22天】
|
15天前
|
应用服务中间件 nginx iOS开发
mac+alfred中的Workflow实现快速格式化nginx配置
mac+alfred中的Workflow实现快速格式化nginx配置
29 0
|
15天前
|
NoSQL Linux Redis
M1-Mac中docker的redis集群配置
M1-Mac中docker的redis集群配置
95 1
|
15天前
|
Linux 开发工具
Linux配置静态ip及克隆出现Mac相同问题
Linux配置静态ip及克隆出现Mac相同问题
37 0
Linux配置静态ip及克隆出现Mac相同问题
|
15天前
|
存储 关系型数据库 MySQL
mysql安装教程mac
【4月更文挑战第21天】
|
6天前
|
前端开发 JavaScript 程序员
HBuilderX使用mac打包ios应用提示苹果根证书没有安装
HBuilderX使用mac打包ios应用提示苹果根证书没有安装
4 0
|
12天前
|
iOS开发 Python
mac:python安装路径,带你全面解析Python框架体系架构view篇
mac:python安装路径,带你全面解析Python框架体系架构view篇