2021年4月-(计算机网络)小型校园网络模拟搭建,最全最准确版!(二)

简介: 2021年4月-(计算机网络)小型校园网络模拟搭建,最全最准确版!!!!!

第四步:路由器A和B配置

配置A

Continue with configuration dialog? [yes/no]: no
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config-if)#int fa0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.192
Router(config-if)#no shut
Router(config-if)#int fa0/1
Router(config-if)#ip address 192.168.1.65 255.255.255.192
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1
Router(config)#ip route 0.0.0.0 0.0.0 192.168.1.66

查看配置后的信息

Router#sh run
Building configuration...
Current configuration : 711 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.65 255.255.255.192
 duplex auto
 speed auto
!
router rip
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.1 
ip route 192.168.2.0 255.255.255.0 192.168.1.1 
ip route 192.168.3.0 255.255.255.0 192.168.1.1 
ip route 0.0.0.0 0.0.0.0 192.168.1.66 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

配置B

Continue with configuration dialog? [yes/no]: no
Router>en
Router#conf t
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.1.66 255.255.255.192
Router(config-if)#no shut
Router(config-if)#int fa0/1
Router(config-if)#ip address 10.0.0.1 255.255.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.65
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.1.65

查看配置后的信息

Router#sh run
Building configuration...
Current configuration : 655 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.66 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.0.0
 duplex auto
 speed auto
!
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.1.65 
ip route 192.168.2.0 255.255.255.0 192.168.1.65 
ip route 192.168.1.0 255.255.255.0 192.168.1.65 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

第五步:配置二层交换机

Switch>en
Switch#conf t
Switch(config)#ip default-gateway 10.0.0.1
Switch(config)#int vlan 1
Switch(config-if)#ip address 10.0.0.2 255.255.0.0
Switch(config-if)#no shut
Switch(config-if)#int fa0/24
Switch(config-if)#sw access vlan 1
Switch(config-if)#no shut

查看配置后的信息

Switch#sh run
Building configuration...
Current configuration : 1039 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode access
!
interface Vlan1
 ip address 10.0.0.2 255.255.0.0
!
ip default-gateway 10.0.0.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

以上就是全部的配置过程

第六步:开始我们的结果验证

以上就是全部的实验内容啦希望能让各位读者看明白,成功完成实验,本人是大学生刚刚自己动手完成的实验,运行成功,就把自己怎么完成实验的过程分享给大家啦,如果对各位有所帮助希望大家能给点赞评论收藏一下,让更多的人看到,谢谢大家的鼓励支持!

如果大家想要kpt文件可以点击这个链接自行来取, https://gitee.com/wanxiaoguo/network3Pro/tree/master

单击下载就可以了

目录
相关文章
|
4月前
|
监控 网络协议 安全
|
2月前
|
缓存 监控 网络协议
计算机网络的常用的网络通信命令(Windows)
本文介绍了网络技术中常用的命令,如ping用于检测网络连通性,ipconfig查看TCP/IP配置,netstat监控网络状态,arp显示和修改ARP缓存,at安排任务执行,tracert追踪路由,以及nbtstat获取NetBIOS信息。
45 1
|
2月前
|
安全 区块链 数据库
|
2月前
|
网络协议 网络架构
【第三期】计算机网络常识/网络分层模型与数据包封装传输过程
【第三期】计算机网络常识/网络分层模型与数据包封装传输过程
56 0
|
4月前
|
存储 网络协议 安全
计算机网络-网络层
计算机网络-网络层
|
4月前
|
网络协议 Java 关系型数据库
16 Java网络编程(计算机网络+网络模型OSI/TCP/IP+通信协议等)
16 Java网络编程(计算机网络+网络模型OSI/TCP/IP+通信协议等)
91 2
|
4月前
|
安全 网络协议 网络安全
|
8天前
|
SQL 安全 网络安全
网络安全与信息安全:知识分享####
【10月更文挑战第21天】 随着数字化时代的快速发展,网络安全和信息安全已成为个人和企业不可忽视的关键问题。本文将探讨网络安全漏洞、加密技术以及安全意识的重要性,并提供一些实用的建议,帮助读者提高自身的网络安全防护能力。 ####
46 17
|
18天前
|
存储 SQL 安全
网络安全与信息安全:关于网络安全漏洞、加密技术、安全意识等方面的知识分享
随着互联网的普及,网络安全问题日益突出。本文将介绍网络安全的重要性,分析常见的网络安全漏洞及其危害,探讨加密技术在保障网络安全中的作用,并强调提高安全意识的必要性。通过本文的学习,读者将了解网络安全的基本概念和应对策略,提升个人和组织的网络安全防护能力。
|
19天前
|
SQL 安全 网络安全
网络安全与信息安全:关于网络安全漏洞、加密技术、安全意识等方面的知识分享
随着互联网的普及,网络安全问题日益突出。本文将从网络安全漏洞、加密技术和安全意识三个方面进行探讨,旨在提高读者对网络安全的认识和防范能力。通过分析常见的网络安全漏洞,介绍加密技术的基本原理和应用,以及强调安全意识的重要性,帮助读者更好地保护自己的网络信息安全。
40 10