【PAT甲级 - C++题解】1140 Look-and-say Sequence

简介: 【PAT甲级 - C++题解】1140 Look-and-say Sequence

1140 Look-and-say Sequence


Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.


Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.


Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111


题意

给定一个 D 和 n ,按照 D 需要输出第 n 项外观序列,而外观序列的规则如下:


第 i 项序列要根据其前一项的序列生成,例如 D 等于 1 ,则第 2 项为 11 ,意思是前一项中 1 出现了 1 次;第 3 项为 12 ,即其前一项中 1 出现了 2 次;第 3 项为 1121 ,即其前一项中 1 出现了 1 次,2 出现了 1 次;第 4 项为 122111 ,即其前一项 1 先连续出现了 2 次,接着2 出现了 1 次,然后 1 又出现了 1 次。


所以可以发现,每项序列是根据其上一个序列的值中每个元素连续的个数来生成的。


思路

具体思路如下:


1.输入起始序列 num 以及需要输出的项数 n 。

2.模拟题目意思,用双指针来生成每项序列,p 指向当前元素,而 q 指向与 p 指向元素相同的连续的最后一个元素的下一个位置,这样 q-p 就是 p 指向元素连续的个数。

3.输出第计算出来的第 n 项序列。


代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string num;
    int n;
    cin >> num >> n;
    //进行n-1次转换
    for (int i = 1; i < n; i++)
    {
        int len = num.size();
        int p = 0;
        string str = "";
        while (p < len)
        {
            int q = p + 1;
            //找出连续相同的字段
            while (q < len && num[q] == num[p])    q++;
            str += num[p] + to_string(q - p);
            p = q;
        }
        num = str;
    }
    //输出第n项序列
    cout << num << endl;
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
76 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
78 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
79 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
134 0
|
6天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
32 4
|
8天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
27 4
|
30天前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
27 4